MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   TechTool reports Finder error??? (http://forums.macnn.com/64/classic-macs-and-mac-os/46952/techtool-reports-finder-error/)

 
Hobbes Jun 27, 2001 08:07 PM
TechTool reports Finder error???
I just purchased my first copy of TechTool. After running it for the first time, it reported quite a few errors. Most of them had to do with dates for files being wrong, which it dutifully fixed. The other error however, was in regard to the Finder.

Here's the deal... I just formatted and reinstalled 2 days ago. I find it hard to believe that my Finder has errors in that short of time, especially errors that TechTool doesn't even give me the option to fix.

Any ideas? Has anyone else had this problem? The manual makes reference to programs that sometimes modify the System, causing TTP to report errors. Is this possibly one of those instances?

Any help would be greatly appreciated.

Oh... BTW, I have a Pismo 400, 320MB RAM, running 9.1.

[ 06-27-2001: Message edited by: Hobbes ]
 
Cipher13 Jun 27, 2001 08:42 PM
Whats the error it reports?

Do a core system install, and replace the System and Finder from the old system with the new one, delete the new one, and rename the old one back to "System Folder".

Also delete the Finder preferences and System Preferences files.

I wouldn't worry about it. Just let it go, theres probably nothing at all wrong. You may have an older version of TechTool, or a new System, or whatever... ignore it unless you're really concerned and the comp has been behaving strangely.

[ 06-27-2001: Message edited by: Cipher13 ]
 
Hobbes Jun 27, 2001 09:22 PM
Thanks for the reply.

As for the error, it happens when its checking the System files. It just says it found an error with the Finder. That part of the check returns a "Fail", whereas the other parts of the System Files check are all OK.

As for it how its running, it runs great. Haven't had a single system lockup since I reinstalled on the 25th. That's why I was thinking it may have been what the manual was saying about some programs modifying the System, modifications that TTP reports as errors.

I'm running 9.1 (from the disk that comes with X) and TTP 3.0.3.
 
crazycylon Jun 27, 2001 09:25 PM
I would have agree with Cipher if you are using a older version of Tech Tool pro version 3.0.2 on OS 9.1 it will report that the finder has errors or is corrupt. If you upgrade to 3.0.3 you won't get that message unless it is really corrupted. I upgraded my verison to 3.0.3 and I no longer get errors messages about the finder.
 
Hobbes Jun 27, 2001 09:32 PM
I checked and the error is with the "Finder file".

Again, running 9.1 (the disk that came with X), and TTP 3.0.3.

Thanks again.
 
reader50 Jun 28, 2001 12:59 AM
The "System Files" test actually calculates checksums for each of the files & compares them against known checksums for each version number of that system file. Any byte that has been modified will throw off the checksum, resulting in a "Fail" report.

The most common false alarm on the Finder is if the Finder's RAM allocation has been increased. Usually by any of several 3rd party utilities. This is not actually an error (the Finder is NOT corrupted), but it will throw off the checksum & cause TTP to report a "Fail" on the Finder.

I would ignore it unless odd Finder behavior and disk errors started happening on a regular basis.
 
Hobbes Jun 30, 2001 10:52 AM
Well, I guess the error was a false alarm after all. After updating to 3.0.4, it no longer reports the error.

Thanks for the feedback.
 
All times are GMT -4. The time now is 06:14 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2