MacNN Forums (
-   Classic Macs and Mac OS (
-   -   System file corrupt (

gMan Aug 8, 2000 06:54 AM
System file corrupt
Well, it's just another one of those things. I shut down my mac, and the next day, it won't boot.
On further inspection I discover that not only has the System file been corrupted, but it has enlarged itself from 15 MB to 1.2 GB! You've got to be kidding...

Norton Disk Doctor revealed (and repaired) some problems with the boot blocks, and Norton AntiVirus revealed nothing. I have installed a clean system file, but i'd be interested to know if anyone has any ideas about WHAT could have caused this - i can't see it as being something which happens for no reason.

Don Foy Aug 8, 2000 04:42 PM
You are right, there is always a reason, but sometimes you won't be able to find it.

One thing that might help is to regularly run your disk utility. I prefer DiskWarrior in conjunction with TechTool Pro (Can't wait to get 3.0 this week), but even Disk First Aid will prevent corruption with regular use. DiskWarrior will help keep the volume bitmap clean so your computer doesn't get confused about where everything is supposed to be on the drive.

If you are regular utility user and it continues to happen, I would investigate hard drive problems.

You don't say what computer you have, so anything else would be even more speculation.
Cipher13 Aug 9, 2000 03:11 AM
Happened to me about a month ago!
Search the forums, use Cipher13 as search criteria as well.
I can't remember whether I worked out why it happened...
Very strange...
OS 9.04 issue obviously...
I did more than just replace the System File though (I think)... can't remember what though. I'll see if I can find the post...

gMan Aug 9, 2000 06:41 AM
I have a Rev B iMac with 96 MB RAM and a 20 GB hard drive which I installed myself (and haven't had any problems with, so far...)
gMan Aug 9, 2000 06:51 AM
Cipher, i couldn't find anything relevant...which forum did you post it in?
grimley Aug 9, 2000 09:51 AM
were you running remote access at the time that you shut down? I had this happen to me a few months ago where the mac was incorrectly shut down and after that the system was showing as 1.2 -1.3 gigs. Turn off all of the extensions associated with RA and restart. see if that helps. If it does, then I have bad news for you. Either you go without the modem or you reinitialize the hard drive. SO I hope that this isn't it.


Gregory Aug 9, 2000 12:59 PM
I run AutoPurge (1.2.3) on restarts to flush anything in the Temp Invisible folder. Have lately "learned' to use DFA first, then either DW or TTP, and to keep the system on its own partition.. Seems to help.

I also don't trust NUM (5.03) so much anymore when it didn't fix a major problem properly (TTP did, hope 3.0 arrives). And using the DW Protect extension w/ 9.0.4 (essential to 8.5/6 but still seems to be helping - crashes in IE had corrupted Directory and maybe driver forcing a couple reformats this year).

I'm also seeing according to CC8 that not only does it think the System file is corrupt (sometimes it really isn't according to MicroMat/TTP), but also the Finder. Installers? Something else? It happens often enough that:

I did a clean install on another partition, applied updates etc, created a .smi read/write file of the folder which I can still mount, apply updates such as MRJ etc and if needed just copy Finder, System, System Resources - just move those to Trash seems okay - and once replaced all the items in this clean Extensions folder to the active system folder.

Sometimes takes longer on a cold boot (memory check is disabled) and couple times zapping PRAM has helped. TTP3 is suppose to diagnose PRAM better I heard.

I really believe 9.0.4 + updates, turning off background processes (control strip etc), reducing 3rd party extensions - I don't trust even a full complement of FileSharing, Security, GameSprockets etc.

Try this - it may be luck, but putting all the Microsoft libraries into Office, First Run for IE and put those in IE (and OE) application folders and NOT leave them in System Extensions.

Checking the Finder/System with CC8.0.7 or TTP even when there aren't yet signs of trouble...

Cipher13 Aug 10, 2000 03:15 AM
Probably in MacOS forum... haven't had any luck finding it either...

All times are GMT -4. The time now is 07:40 PM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

Content Relevant URLs by vBSEO 3.3.2