MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   OS 8.6, VPC 2.1.3, Macally conflict/crash (http://forums.macnn.com/64/classic-macs-and-mac-os/47597/os-8-6-vpc-2-1-a/)

 
MacNN Reader May 13, 1999 05:30 AM
OS 8.6, VPC 2.1.3, Macally conflict/crash
I believe I have found a conflict between the Mac OS 8.6, Virtual PC 2.13, and the MacAlly PointDevice 3.1 software used to operate their 2 button ADB mouse.

My system is a 7500 with a 233Mhz 604e card with 112 megs of ram. Everything had been running fine with no crashes in 8.5. I then updated VPC to 2.13, since I read this was needed to run it in 8.6. I ran VPC a couple of times after this and didn't see any problems. I then updated my system to 8.6, and VPC would lock up the computer (the mouse would freeze, sometimes I would get errors saying "error type 10" or "illegal instruction" and that I had to restart, but other times it would just freeze completely.

I tried no extensions and then in extensions manager I choose "8.6 all", and both had no problems. From there I added 6 extensions and Control panels that I thought might be trouble, and then narrowed it down to the 2 extensions and 1 control panel from MacAlly's PointDevice version 3.1 software (this is PointDeviceDaemon.2m, PointDeviceINIT and Point Device). Note that "macally input sprocket", which is a separate install, did not cause any conflicts.

I also tried these 3 individually. It appears that the control panel Point Device is only an application, and doesn't have any functionality by itself. But when it is opened it appears to install the 2 extensions, much like Iomega Guest does. Before launching it there is no conflict, but it also doesn't give any of the 2 button functionality. After opening it it does cause the conflict with VPC, but does act as a 2 button mouse in the finder and other apps.

PointDeviceDaemon.2m by itself freezes up the mouse in the finder. The keyboard still works, as I was able to open up sherlock and search for the mouse control panel....but life without a mouse is not what I am looking for.

PointDeviceINIT by itself gives the functionality of a 2 button mouse in the finder and other apps, but locks up VPC on attempted start up. Since this is the symptom I originally saw it is probably this extension's fault, though the PointDeviceDaemon.2m might play a role too.

If you need any further information or have a solution, please e-mail me at aaron25@home.com

I am sending this out to various places including MacAlly, Connectix, Apple, Macintouch, MacGamers Ledge, xlr8yourmac, and other web sites that are tracking issues with the 8.6 update.

Aaron Daniel
 
All times are GMT -4. The time now is 11:05 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2016, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2