MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   Keyspan USB Card and Superdisk Problem on 8.6 (http://forums.macnn.com/64/classic-macs-and-mac-os/47651/keyspan-usb-card-superdisk-problem-8-a/)

 
MacNut May 12, 1999 09:16 PM
Keyspan USB Card and Superdisk Problem on 8.6
Hello,
System:Power Mac G3 233 Desktop running OS 8.6
Here is my problem, I recently purchased a Keyspan USB card and installed it along with a Imation Superdisk drive ( the new 2X version ).
I installed the Keyspan drivers and the Imation drivers and restarted the computer.
Here's the problem.... the computer fails to mount the Superdisk image on the desktop as expected even though the drive spins up.
Through experimentation I discovered that if after start up I unplug the USB cord from the Keyspan card and plug it back up in a couple of seconds and then insert the Superdisk into the drive the disk mounts on the desktop as expected.
Here's where it gets intresting....I decided to reformat the Hard drive and reinstall OS 8.5.1 and then reinstall the Keyspan drivers and the Imation drivers, to my amazement the Superdisk drive worked perfectly every time I inserted a disk without me having to to unplug and replug the drive on startup.
I thought that I had the problem solved so I reinstalled the OS 8.6 Update.
To my dismay this caused the Superdisk to fail to mount the floppy image as described eariler, again unpluging the drive and repluging it on each start up would cause the image to mount.
I thought that it was being caused by the USB drivers installed by 8.6 so I decided to replace the 8.6 drivers with the ones that came From Keyspan and Imation.
This solution did not fix the problem.
The only thing that will make the drive mount correctly without me having to plug/unplug the drive is to reformat the drive and run OS 8.5.1
With 8.5.1 the drive works as expected, but I would really like to be able to run OS 8.6
I have tried to Install the new USB storage update 1.3 that was released yesterday when I was running 8.5.1 and 8.6 but each time the installer responds that that the update is not intended for this computer.

If anyone can help please respond as I have tried everything that I know to do.
You can Email me or respond in this forum.
macnut@mindspring.com
Thanks in Advance
Greg Williams
I found the solution....
I downloaded USB DDK V 1.2 and modified the resource code as decribed by Apple and put the new ext in the system folder and discarded the old ones as instructed.
I retained the USB ext supplied by Keyspan and Imation.
The Drive works correctly now.


[This message has been edited by MacNut (edited 05-13-99).]
 
MacNut May 13, 1999 11:51 PM
Problem fixed see original post for details.
MacNut
 
All times are GMT -4. The time now is 11:16 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2