MacNN Forums (
-   Classic Macs and Mac OS (
-   -   iTunes running jerky ( Aug 11, 2001 06:32 PM
iTunes running jerky
Recently downloaded iTunes to my son's iMac 400mhz DVD machine and allocated it 10500K to run on, which should be more than enough, but the visualiser it runs VERY jerkily despite this. Since he is a big iTunes visualiser fan when it runs on MY computer and the idea was to stop him sneaking in to use it, any ideas why it's running slow and poorly? The SOUND is ok, it's the visuals that are weak. He has 256 RAM installed and is running system 9.1.

All ideas welcome - thanks.

[ 08-11-2001: Message edited by: ]
SirCastor Aug 11, 2001 09:32 PM
I don't know that there is a solution to this. I suffer from occasional jerky visuals as well. There are a couple of things you can try. If you turn on Visuals, the browse button in the upper right hand corner turns into an options button.
There you can turn on or off Cap Frame Rate @ 30 fps, and 'faster but rougher display'

Sometimes they help, sometimes not. I'm on a G4 400, but I still don't have it smooth as silk. (I Run into it with OS X too...)
I think (and I'll proabably be jumped on for this) the visuals haven't been optimized. They came from a different company, and Apple may not have (and may never) change(d) the code very much. Who knows..
Simon Franklin Aug 12, 2001 09:26 AM
Few thoughts:

is your software completely up to date - including iTunes 1.1 and iMac firmware update 4.1.8?

Try even more RAM - if your running the visualizer then you are obviously not needing to allocate any RAM to anything else. RAM is so cheap that its almost worth adding another 64MB even if you don't need it for anything particular. I've always found that iMacs and iBooks run so much better when they have more RAM installed than they came with.

Are there any processes in the background - hard drive indexing for example?

Are you playing tunes off the hard drive or off CD? Hard drive will obvously be more reliable.

Do you have Energy Saver set to spin hard drive down at all?
Fredo Aug 14, 2001 07:49 PM
I agree with Simon concerning RAM. Try setting both minimum and preferred memory allocations to 24000 and see if this helps. Aug 14, 2001 08:10 PM
Originally posted by Fredo:
<STRONG>I agree with Simon concerning RAM. Try setting both minimum and preferred memory allocations to 24000 and see if this helps.</STRONG>
checked out the update situation adn everything registers as ok there. I already had increased the memory allocation to 25000, but will clock it higher and higher on the offchance. It's occasionally naughty on the G4 tower as well, and it's PACKED with power there. But better, admittedly. Ok. Will try allocating EVEN MORE ram in the memory panel and take the tip that the programme is somewhat - um - erratic on board too. Will keep trying. My son sends his thanks...
Gregg Aug 18, 2001 04:50 PM
janice, you know, anyone who sees this now has your e-mail address...
milhous Aug 19, 2001 03:41 AM
be sure that you have virtual memory disabled.
All times are GMT -4. The time now is 10:51 PM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2015, vBulletin Solutions, Inc.

Content Relevant URLs by vBSEO 3.3.2