MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   CD player won't work after clean-install (http://forums.macnn.com/64/classic-macs-and-mac-os/63674/cd-player-wont-work-after-clean/)

 
sellart 2 Aug 2, 2001 01:20 AM
CD player won't work after clean-install
I recently purchased a used PowerBase 240 with OS 9.04. The CD player worked just fine until I did a clean install with 9.04. Since then, the CD player does not function. I've tried to startup with the 9.04 disk, holding down the "c" key -- but have had no luck. None of my CDs appear on the desk top when placed in the player.

Anyone have any ideas?
 
jeromep Aug 2, 2001 01:58 AM
A couple of things:

Does the drive show up in the system profiler?

If not then the drive may be fried or dead. There is a current thread in here about CD roms in clones dieing after some time. Better check that thread first.

I'm also thinking of the fact that the drive may appear as third-party to the system and the Apple CD extension(s) don't see it as an Apple CD and can't drive it. That means that if the drive still works, then you need to go out and get third party CD-ROM dirvers.
 
MacMonster Aug 2, 2001 03:19 AM
I heard that if you use third-party CD-ROM drive, you need the CD-ROM extension from OS 7.6. Try copy the Apple CD-ROM extension from 7.6, and see it works or not.
 
David Burgoyne Aug 2, 2001 01:59 PM
Where do you find drivers to download?
 
<anonymous> Aug 2, 2001 02:57 PM
Check to make sure all of your CD ROM related extentions are enabled in the Extensions Manager. Maybe there is something else you need to enable that the clean install didn't do automatically. Check your 'old/previous' system folder for other related extensions and move over to your new one manually. I don't follow why you would need OS 7.6 stuff for OS 9.0.4.
 
jeromep Aug 5, 2001 01:51 AM
You don't download the drivers, you BUY them. FWB CD-ROM Toolkit comes to mind. I think that Hard Disk Toolkit will also allow you to mount CD-ROMs, but I'm not absolutly sure about that. But all of the above assumes that you aren't suffering from a fairly typical fried older clone CD-ROM drove syndrom. You may still have a dead drive. It is hard to say without applying third party drivers and seeing if the drive works.

Also, Apple removed any support for third party CD-ROMs from at least 9.0 and up if not a bit earlier, like 8.5. Since your clone doesn't have an Apple branded CD-ROM, it is third party and therefor isn't supported by the Apple CD-ROM drivers. Likewise, if you do find an older CD-ROM extension set it is a shot in the dark as to whether or not it will support your clone's drive.

Keep in mind, the OS You are trying using on your clone isn't officially supported for it, and the CD-ROM issue you are having is an excelent example why it isn't supported.

You might be better off running 8.6 on it, no guarantees on how well your CD-ROM will run after an install of that.
 
King Chung Huang Aug 5, 2001 08:40 PM
All of the Power Computing machines came with FWB CD-ROM Toolkit to run their CD-ROM drives. I got tired of having to install that for my PowerTower Pro, so I replaced the CD-ROM drive with one from Apple so that it works with Apple's drivers. You can modify the 'Apple CD/DVD Driver' extension to make it work with third party drives. Try searching ResExcellence for that.
 
All times are GMT -4. The time now is 11:14 PM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2