MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   PM 7200/120 SCSI Hard Drive Problems (http://forums.macnn.com/64/classic-macs-and-mac-os/64658/pm-7200-120-scsi-hard-drive/)

 
Larry767 May 27, 2002 05:18 PM
PM 7200/120 SCSI Hard Drive Problems
I have an old PM 7200 that recently got retired from service.  It had been running OS 9.1 but I decided to do a low level format and reinstall from scratch so I could give it to another user on our network.  I booted from the OS 9.1 retail CD and used Drive Setup to initialize the drive.  I then proceeded to install OS 9.1 which went without a hitch.  However, when I rebooted, I got the flashing disk.  I reinserted the OS 9.1 CD and found that the hard drive would not mount.  I then reran Drive Setup again and rebooted the computer from the CD.  Again the drive would not mount.  I booted from an emergency CD I had and ran Nortun Disk Doctor.  It was unable to recognize anything on the drive.  I tried formatting using Hard Disk Speed Tools and a number of other tricks, including replacing the SCSI cable.  Nothing I've tried seems to work.  Drive Setup or any other formatting utility report no errors yet everytime I reboot the machine, the hard drive gets corrupted.  I've verified this with two different SCSI drives too, and both of them are good - they work fine in another machine.

Any ideas?
 
Rainy Day May 27, 2002 06:46 PM
It's entirely possible that the low level format you did trashed the drive. One should avoid low level formats at all costs, especially on older/high mileage drives, as this can cause/induce bad block formation (has to do with the magnetic properties of the disc surface over time/use). High level initializations, because they do not alter the blocks' physical locations on the disc's surface, are okay.

Normally, bad blocks are marked as "bad" and spares are used in their place (with a corresponding performance penalty), but there are certain blocks which cannot be substituted in this manner. I believe the driver, spares table, and volume table of contents are examples of blocks which cannot be substituted (as they are expected to be at certain absolute locations on the disk).

Given the symptoms you described, my guess would be you now have a bad block lurking somewhere in the driver portion of your HD. This would explain why you were able to run the MacOS 9 installer immediately after running HD Setup (because HD Setup loaded a driver into RAM for you), but are unable to boot from or otherwise mount the volume after a restart (because now the driver is being loaded from the HD, but that area of the disk is corrupt).

Chances are good that a bad block scan from something like Norton might not detect bad blocks in this area of the HD (assuming you could run Norton on this disk). Your best bet would be to run a bad block scan from a formatting utility (e.g. HD Setup).

You might be able to fix the disk by doing another low level format. It may take more than one attempt (if it's going to work at all). My suggestion is to do the low level format, then immediately reboot off CD (i.e. without installing MacOS). If the newly formatted drive mounts, you can assume you've fixed the problem and proceed with installing the MacOS. Only after you get the drive to mount, assuming you can, but before you install the MacOS, i would do a complete Drive Test from HD Setup, or whatever formatting program you're using.

If that doesn't work, you'll have to deep six the drive and replace it with another.
 
All times are GMT -4. The time now is 09:07 PM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2016, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2