MacNN Forums (
-   Classic Macs and Mac OS (
-   -   Powerbook 170 Hard Drive (

Steph Jul 12, 2000 10:47 PM
Powerbook 170 Hard Drive
I have a Powerbook 170, into which I've installed an IBM 810 Mb hard drive. My problem is that the Powerbook (running System 7.1) insists that the drive is only 270 Mb. I'm using Apple HD SC Setup v7.3.5 to initialize it. The drive has been initialized and I've updated the driver on it, and I'm using it -- all as if it were a 270 Mb drive.

Can anyone tell me -- Is there a size-limit to the hard disk, under either a PB170 or System 7.1? Is there any way I can get the PB to recognize that the drive is really 810 Mb?

reader50 Jul 13, 2000 12:36 AM
System 7.1 will go up to 2 Gig. reference.

You could go up to System 7.5.5 for free, but that would take up a bit more of your memory.

Try reformatting the drive with Drive Setup, then use HD SC Setup to update the driver. The driver that Drive Setup installs will not work with an 030 Mac like the PB 170 or anything earlier. BTW: after formatting with Drive Setup, the drive will appear on the desktop. Don't trust this. The next time you boot up the drive will not show up until you use HD SC Setup to install the older driver.
Steph Jul 13, 2000 01:45 AM
Thanks for the info! I've searched Apple downloads, and can't find a version of Drive Setup that will run on 7.1 -- so I've been downloading 7.5, and installing it on an external scsi hard drive. Then I can boot from the external in 7.5, run Drive Setup (as it will run on 7.5 and up) and hopefully get my full 810 Mb.

I might then just stick with 7.5, I'm sure it has a number of advantages over 7.1. Memory may be an issue, though I have the full compliment of 8Mb.

Thanks again for the info.

Steph Jul 13, 2000 03:02 AM
Now I'm at a total loss... I downloaded and installed 7.5.3 then the update to 7.5.5, I've tried both Drive Setup and HD SC, and this 810 MB drive keeps coming up as 270. The drive has the original labels on it, it's an IBM and I've been to their website and checked their documentation, and the part number definately reads as an 810 MB drive. Somehow though, either it or the Mac has decided it's only 270... I'm stumped. Maybe it's a bad drive?

Steph Jul 13, 2000 03:03 AM
Sorry -- double post.


[This message has been edited by Steph (edited 07-13-2000).]
reader50 Jul 13, 2000 03:24 AM
Can you hook the 810 drive into a different Mac to take a look at it? A more recent Mac could use Drive Setup, as well as Apple System Profiler. You could confirm the size, as well as format it. You would still need to update the driver with HD SC Setup after returning it to the Powerbook 170.

One other possiblilty. On my recently purchased 2nd ATA hard drive, the documentation mentioned a jumper setting that would make the drive pretend to be smaller that it actually is. This was provided to make the drive work with obsolete BIOS stuff on peecees that could not address large modern drives.

I have never heard of this being done on a SCSI drive, but I noticed that 270 Megs is exactly 1/3 of 810 Megs. If you check the IBM support documents you might find something. Are there any jumper blocks on your IBM drive other than the SCSI ID settings?
Steph Jul 13, 2000 09:32 AM
Reader50, unfortunately I have no other computers which will accept a 2.5" SCSI drive. There are no jumpers at all on it, and I've read IBM's documentation on the internet about it, I saw nothing mentioned about 'changing' it's size.

I just noticed something strange though, in SCSI-Probe, the drive identifies on there with a different model-number. I looked it up, and it's showing the model-number of an IBM 270 MB drive, then there's an exclaimation mark after the #.

Thanks again for all the help.

MacOS761 Jul 13, 2000 10:57 AM
Perhaps the drive is partitioned? Hard Disk Toolkit can fix that for you, but this whole problem is strange indeed. Did you go ahead and format the drive? I don't know if formatting the "drive" actually formats a selected partition or the whole physical drive, so I would suggest finding a way to try "de-partitioning" the drive.
Steph Jul 13, 2000 12:02 PM
I have 'initialized' the drive several times, and tried repartitioning it. The only hard drive utilities I have are Drive Setup and HD SC Setup, no 3rd party utilities.
I'm going to see if IBM has any more information to offer on this... Maybe they have some kind of e-mail tech support or something

Thanks again for all the help here!


ps System 7.5.5 is a lot more fun than 7.1, and faster too! If nothing else comes of this, at least I've already made that improvement.
Anthology123 Jul 24, 2000 06:26 PM
If you partition the drive, what does the total drive say in that partition diagram? Maybe you got the wrong drive and it is a 270, since SCSI probe thinks it is. I use system 7.5.3 on a PB 100 with 8 mb, 120 mb HD and it runs just fine. Go ahead and do the OS upgrade.
Tim Michael (finboy) Jul 24, 2000 09:15 PM
I can't believe that 7.5 is faster and smaller (in RAM) than 7.1.

See if you can get an older copy of FWB's Hard Disk Toolkit or Charismac's Anubis and format the drive that way. I know that Anubis will run with older processors if you get the right version. They may even sell that version currently.

Also, contrary to prior posts, I could never get 7.1 to recognize an 2G drive in my LC520 or my LCIII, no matter what I tried. I HAD to go to system 7.5 to get 2G drives in 68030 machines.
Tim Michael (finboy) Jul 24, 2000 10:22 PM
I have the answer!!!! Interleave.

On the older PBooks, you have to set the interleave (through the formatting software) because the SCSI in the PB isn't fast enough to keep up with the spinning drive.

I don't know if Apple's software will let you do that, but you can check. I know that most third party drivers will allow for a user-set interleave. Here you probably want 3:1 (hence the ratio mentioned above).

No, no, don't thank me. Just trying to make the world a better place. Really.
Tim Michael (finboy) Jul 26, 2000 08:56 PM
What's the poop? Did changing the interleave work?

Inquiring minds want to know.
Steph Jul 27, 2000 01:12 PM
First off, thank you all for your help in this puzzler. Here is the final wrap-up. The model-number the drive identified itself as with SCSI-Probe was a non-existant model. I had correspondence with IBM tech support (fantastic, the drive is 4 years old, I got it at a garage sale, and they still responded to my e-mail within hours) but alas they were just as stumped.

No matter what I tried, (re-initializing, low-level formatting, zeroing all data, repartitioning) the drive stubbornly stayed at 270 MB.

I investigated some 3rd party drive utilities, but was unable to find any that were available for free. At long last, I realized how much time and energy had gone into this puzzle, for a drive that had cost me $5, and realized that this was a losing proposition. I haven't entirely given up... I have just put this project away for now.

As an aside, System 7.5.5 does indeed use much more RAM than 7.1 did (abt. 4 Mb vs 1.5 Mb) but it is faster, and much neater. My earlier posts may not have been clear on this point.

Again, thanks to all who have helped!


8ball Aug 12, 2000 05:37 PM
See if you can find a copy of Drive Setup 3.01au
It was made when Apple was experementing with unix but never released to the public. If you get and use it,use a regular Drive Setup afterwards. I found 3.01 will format almost anything that spins, but I don't trust it for the long run. Its great for unsupported drives to make them supported.
All times are GMT -4. The time now is 08:25 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

Content Relevant URLs by vBSEO 3.3.2