MacNN Forums (http://forums.macnn.com/)
-   iPhone, iPad & iPod (http://forums.macnn.com/iphone-ipad-and-ipod/)
-   -   YouTube Unusable on Apple TV, iPhones (http://forums.macnn.com/103/iphone-ipad-and-ipod/430258/youtube-unusable-on-apple-tv-iphones/)

 
DigitalEl Dec 29, 2010 08:42 PM
YouTube Unusable on Apple TV, iPhones
My network is a better than average 9 to 20 down, 2 to 6 up. I have no trouble with network speed on my iMac. I can push both audio and video around the house with no problem using AirPlay or my Apple TV. I can rent a movie from iTunes on the Apple TV and it's ready to watch in 15 seconds and doesn't hiccup for 2 hours. Same with Netflix (during non-peak hours, at least). Watching a simple YouTube clip though... Pretty much undoable. The video will either load for a full five minutes, then play, stopping a few times in the middle to buffer more (this is on a short video of less than 5 minutes). Longer videos will just buffer 'til I give up, with the Network Activity spinner spinning away incessantly.

Then sometimes, even a 30 minute YouTube will play instantly and flawlessly... But that's 1 time out of 10.

The behavior is exactly the same on my household's 3 iPhones... Under both Wi-Fi and 3G. On the phones, it doesn't matter whether the video clip is accessed through Safari, Twitter for iPhone or the built-in YouTube app.

There's no time of day pattern. No-one else is ever doing anything on the network. It's just YouTube on iOS. I could access the same videos on the iMac (Wi-Fi) and they'd play with zero problems.

Is anyone else seeing anything like this?
 
Cold Warrior Dec 29, 2010 08:48 PM
I see it on my old 3GS and current iPhone 4. No issues on 3G, but all the time on wifi regardless of location.

Try this: on your iPhone in Safari go to m.youtube.com and see if your issues persist. Try out the HQ button too. If this works well for you, just add it to your iPhone home screen and move the YouTube app out of sight.
 
DigitalEl Dec 29, 2010 08:54 PM
Thanks for the tips there. Will try those on the phones... The Apple TV is still a YouTube brick though.
 
Atheist Dec 30, 2010 12:23 AM
I find YouTube frequently unusable on my Apple TV and iPhones as well... but just fine on my desktop. Is there any plausible explanation behind this?
 
laieboy Dec 30, 2010 01:26 PM
I have no issues on my iPhone 4 and my Apple TV with YouTube. Hope your problem gets resolved soon. I love watching YouTube HD on my Apple TV.
 
Andrew88088 Dec 31, 2010 02:44 AM
This is an issue for me as well. I have an iPhone 4 and iPad, and when connected to wifi, Youtube always takes forever to load. I just got an AppleTV last night and loaded up a Youtube video earlier this evening, and sure enough, it crawled. If I get on my MacBook and load the same video, it loads quickly with no issues. I don't get it, but it's rather irritating.
 
subego Dec 31, 2010 03:00 AM
Some people have reported YouTube behaving better with OpenDNS.
 
DigitalEl Dec 31, 2010 02:45 PM
Quote, Originally Posted by subego
Some people have reported YouTube behaving better with OpenDNS.
SOLVED.

I cross-posted this thread on the Apple support communities forum and someone pointed to DNS being a possible culprit. I found another DNS and manually pointed everything on my network (router, Mac, 3 phones, Apple TV) to the new settings and voila! YouTube loads as one would expect on all devices.

I think I'm gonna go buy a Networking for Dummies book so I actually grok what I did.
 
subego Dec 31, 2010 04:18 PM
Just to prepare you...

I have the YouTube problem, switched to OpenDNS, and still sometimes get janky YouTube, which is why I described it as a potential-like solution.

Also, just yesterday, I read an article that claimed people who were using OpenDNS were having slow downloads from the iTunes store. Supposedly this is because the Akamai servers Apple is using are (approximately) geolocating you through your DNS, and then picking the closest server from that. Since it can't do it with OpenDNS, everyone using it gets routed to the same server, it overloads, and your download slows to a crawl.

FWIW, I haven't noticed any problems since the switch. The iTunes servers have always seemed dog slow to me anyways.


Edit: it looks like you may not be using OpenDNS, so never mind. :)
 
subego Dec 31, 2010 07:05 PM
Quote, Originally Posted by DigitalEl (Post 4039375)
I found another DNS and manually pointed everything on my network (router, Mac, 3 phones, Apple TV) to the new settings and voila!
One more thing... if you're using DHCP, You should be able to hook the DHCP server on your router with your chosen DNS addy, and it'll automatically serve that DNS up to everything on your network.
 
DigitalEl Dec 31, 2010 07:18 PM
Quote, Originally Posted by subego
looks like you may not be using OpenDNS, so never mind.
I'm not. I remembered the stories from a couple of weeks ago ref. OpenDNS, so didn't want to go that route.

Quote, Originally Posted by subego
One more thing... if you're using DHCP, You should be able to hook the DHCP server on your router with your chosen DNS addy, and it'll automatically serve that DNS up to everything on your network.
Thanks for the info. Will do that.
 
subego Dec 31, 2010 11:59 PM
Quote, Originally Posted by DigitalEl (Post 4039422)
I'm not. I remembered the stories...
I saw your post and thought "crap, they have another problem too?"
 
All times are GMT -4. The time now is 11:01 PM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2016, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2