MacNN Forums (http://forums.macnn.com/)
-   iPhone, iPad & iPod (http://forums.macnn.com/iphone-ipad-and-ipod/)
-   -   iPhone 4S, iOS 6.1.3, and WiFi Problems (http://forums.macnn.com/103/iphone-ipad-and-ipod/499513/iphone-4s-ios-6-1-3-a/)

 
ghporter Apr 5, 2013 11:56 PM
iPhone 4S, iOS 6.1.3, and WiFi Problems
I've had my iPhone updated to 6.1.3 for about a week, and it runs fine on my home WiFi, my work WiFi, Starbucks and Barnes & Noble's WiFi, etc... But visiting out of town, it will not join an in-law's WiFi network, despite numerous attempts with entering the password, turning the phone's WiFi off and on, and rebooting the phone. My wife's 4S is still on 6.1.2, and it joined the network automatically, as I expected mine to.

Research shows that this isn't an entirely unknown issue, but mine is different in that it worked on a number of networks but not this one particular network (my iPad with 6.1.3 joined without a hitch).

Any ideas?
 
P Apr 6, 2013 11:12 AM
You could try the Reset Network Settings option (Settings -> General and then the bottom option) but that would lose you all saved passwords.
 
ghporter Apr 6, 2013 08:28 PM
That's the thing, I don't want to lose everything else for the possibility that I might fix connecting to one specific network. I was hoping there might be another possibility.
 
ghporter Apr 12, 2013 06:23 PM
On the way home, I noticed that I couldn't connect to a public network I'd used many times in the past, but when I got home, my phone connected to my home network, and more important, my work network. I still have no idea why it didn't work with the two networks while I was visiting, but I'm glad I didn't wipe out my network settings with a reset.
 
ghporter Apr 24, 2013 07:13 AM
I wound up restoring my phone, but I haven't gone anywhere to see if it has fixed the issue I was having,
 
CentralParkMac Apr 25, 2013 12:20 PM
Hi,

There are several users facing the exact same problem, their WIFI has greyed out ever since they updated the version.
 
techahead Apr 26, 2013 08:02 AM
it could be an encryption problem see what encryption policy is being used use the same your in-law's are using
 
Spheric Harlot Apr 26, 2013 10:26 AM
Quote, Originally Posted by techahead (Post 4227867)
it could be an encryption problem see what encryption policy is being used use the same your in-law's are using
This wouldn't affect the public Wi-Fi he was no longer able to connect to.
 
ghporter Apr 28, 2013 01:17 PM
To be clear, my WiFi was not grayed out; the phone simply said (immediately) "cannot connect to..." Restoring the phone didn't help at all, it seems, but resetting the network settings did, as far as I can tell. All the hot spots I've tried since resetting have been easy to connect to.

The problem was never encryption, not only because it happened with open networks as well as encrypted ones. My brother in law's setup uses WPA2, with an easy to enter (though quite random) password, and I entered it carefully each time I tried. The public hot spots that worked before my update gave me exactly the same error message as what I got at his house.

I'm still puzzled why certain open WiFi nets, and certain encrypted nets that I had used very easily in the past would have stopped working, while the ones I used all the time, home and work, continued to work great. Unless there's some gremlin attending to how frequently a hot spot was used and only borking the less commonly used ones, it should have just stopped connecting at all...
 
techahead Apr 30, 2013 04:21 AM
Quote, Originally Posted by Spheric Harlot (Post 4227883)
This wouldn't affect the public Wi-Fi he was no longer able to connect to.
Hmm, hi ghporter I think reset is the only option that might work for you, you can try this if you want.

Quote
Go to your Settings --->General--->Reset--->and choose, Reset Network Settings. This will clear all of the past tries to connect to Wifi. Once you reset, go back into your Wifi options and will be able to see your router. Once you choose it, it will ask for your security code and everything should connect fine
 
Spheric Harlot Apr 30, 2013 04:30 AM
Techahead, have you considered reading the thread you're replying to?

Just an idea.
 
joshu22 May 24, 2013 11:45 AM
facing the wi-fi problem
I have faced wi-fi problem with my iphone 4S and i think it has something to do with the range of the wi-fi router, and not having long range of wi-fi antena in the iPhone?
 
ghporter May 24, 2013 09:43 PM
My problems started after I upgraded the OS. With this same phone, I had been able to connect to any WiFi network that I had a password for, and of course all open networks. After the upgrade, that changed. Obviously it cannot have anything to do with the phone's antenna in my case.

I have reset network settings, manually entered network data, and even restored the phone, all without any change to the problem: I am not able to connect to SOME networks that I had been able to connect to before.
 
P Jun 24, 2013 10:03 AM
Did you ever find a solution to this problem? Had to do some family tech support this weekend, and it appears that they have the same problem. Doing Reset Network Settings cures it temporarily, but it dies again fairly soon.
 
hab Jun 25, 2013 12:18 PM
Similar problem with my 3GS (I know, time to upgrade). Since OS 6.1.3, in order to connect, I have to be very close to WiFi sources that I used to be able to connect at distance or in other rooms. I figured it was my phone that was failing but this thread has me thinking that the OS change is a factor.
 
ghporter Jun 25, 2013 08:31 PM
I had noted a similar problem with my 4s. I posted previously that I had reset network settings and restored the phone, but doing both of those wasn't effective. Just this past week, I just reset my network settings, and lo and behold, I was able to connect to a lot of hotspots that I had not been able to connect with earlier. Interestingly, we visited my in-laws again this past weekend, and my brother-in-law had had to have his 2-Wire access point/router replaced; maybe that was part of my own problem. Whether it was or not, I was able to connect to his network with my phone just by entering the password. It worked great, and I did not see the same sort of "have to be near the access point" issues anymore.
 
All times are GMT -4. The time now is 11:42 PM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2016, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2