MacNN Forums (
-   Mac Desktops (
-   -   My FireWire ports blew - BOTH of them (

BWilliams Jan 29, 2013 12:21 AM
My FireWire ports blew - BOTH of them
This is my first post. I assume it's in the right place. If not, please move it.

I have a 2006 iMac with Lion on it. It started acting up. I'd call it typical signs of a drive failure. Spinning beach balls, and once in a while I get a "cannot read or write" message or something like that. I got a copy of Scannerz to test it figuring it would point me right at the hard drive. I'm talking about the internal hard drive not the external hard drive. I did a scan on the disk and was getting errors and irregularities throughout the test. It didn't make sense to me because if the drive is that bad a shape I figured it would be unusable. I contacted the company that makes the software and they told me it was either likely a system fault developing or a bad cable and then steered me through some of the troubleshooting procedures. I had a bootable clone of the OS on my FireWire drive. They said I should boot off of it, unmount the main drive to do some tests.

......So....I shut the system down, plug in the FireWire drive, power the system on, and a few seconds later I smell the odor of an electrical short. I thought it was my imagination. The system came up and didn't acknowledge the drive. I shut it down, plugged it into the other FireWire port and it still wouldn't see the FireWire drive. This is a Maxtor unit with both USB and FireWire ports on it, so I tried it off of the USB ports (all of them) and the drive is seen. I put the FireWire cable back into the unit then plugged it into an old iBook I gave to one of my kids, and it's seen. There's nothing wrong with the external drive - the FireWire ports blew.

Oddly, now the unit is working fine, or at least has been for a week. I personally liked old configuration because FireWire seems to me to be faster than USB. I know USB has a higher data rate, but FIreWire has always seemed faster. Tech support for the Scannerz people told me there was likely an intermittent short FireWire circuits in the system and when it finally made contact long enough to blow, it blew the ports.

Are FireWire ports blowing a common problem? I've heard of people losing one of them at a time but I've never heard of anyone losing all of them at the same time. Is this system safe to use? It looks like it's working fine now, but how do I know for sure?

Here's the real kicker: Apple's self diagnostics report everything is up and running fine!
Spheric Harlot Jan 29, 2013 02:10 AM
USB 2.0 does NOT have a higher data rate. It has a higher nominal maximum throughput, but as that is CPU- dependent and comes in bursts, USB 2.0‘s sustained data rate is ten to twenty percent slower than that of FireWire 400, and it's not even close to that of FW 800.

Also, I'm pretty sure that the only machine ever to come with two separate FireWire controllers was the Mac Pro. All other machines have both FireWire ports (if they have two) running off a single controller, so if that blows, they both die.

FireWire chips would blow all the time prior to 2002 IIRC, because Apple violated their own specs and built in subpar overcurrent protection on their chips before then. It hasn't really been a problem since, though of course that doesn't mean it cannot happen, especially since defective external hardware might be an issue, as well.

Start the machine in verbose mode (hold down "v" on startup). This will boot the machine normally, but it will show you the status messages as text during the boot process. If the FireWire chip is blown, it will show the message "broken FireWire PHY" at some point during the early boot process, as it checks its ports.
BWilliams Jan 29, 2013 05:19 AM
I took your advice and booted in verbose mode. The FireWire controller didn't have any problems listed. HOWEVER, I went to /var/log and did a grep for "FireWire" and the daily.out log is indicating that the FireWire controller initializes, and then at 3 minute intervals it reports itself as resetting because there are "no valid self IDs" or something like that. This occurs ONLY after the event that apparently damaged the unit occurred. The good news is that it isn't reporting any other errors related to hardware, so maybe I'll be alright just using the USB when needed (even though I hate it).

Thanks for clarifying the USB vs. FireWire speed issue. I KNEW it wasn't my imagination.

I'm assuming I had an intermittent short somewhere in the FireWire connections on the logic board that finally made contact long enough to blow something. However, the FireWire is generally used as a backup, in fact a clone of the original drive, and it wasn't connected during the problems I was originally having with the system. When I plugged in the drive as per the Scannerz guy's suggestion, whatever was bad, blew. I can't figure out how an intermittent short in the FireWIre unit (which to me now means chip(s), traces, supply lines, etc) caused problems when they weren't in use.

Any ideas?
Spheric Harlot Jan 29, 2013 08:36 AM
Try resetting the SMC:

Shut down the computer.
Unplug the computer's power cord.
Wait fifteen seconds.
Attach the computer's power cord.
Wait five seconds, then press the power button to turn on the computer.

Intel-based Macs: Resetting the System Management Controller (SMC)
reader50 Jan 29, 2013 03:26 PM
I'd suggest buying a new FW cable and tossing the old. If your cable has an intermittent short in it, it will eventually screw with any port its plugged into. Since the cable flexes, it is a much likelier problem source than the motherboard controller.

As to settling down the motherboard controller, I have no suggestions to add.
D R Turbo Jan 29, 2013 07:03 PM
No one can really tell what happened to your system at this point without opening the unit up. I could however, offer an educated guess.

Scannerz is fault detection software, it isn't just hard drive testing software. I would wonder if something conductive, like a small metal shaving didn't work it's way into your system and start making contact between some of the lines associated with the FireWire. If these were intermittent and short in nature, it cause the CPU to think it needs to service a port, and Scannerz detects it as an irregularity. At this point there is no electrical load on anything associated with the FireWire port. The moment you plugged the FireWire drive in and the intermittent contact was made, instead of working against what was an open circuit it's now working against a loaded circuit. I would suspect this caused a trace, not a chip to blow. If this happened, your FireWire port would still look functional to the system but lines (like supply and ground) to the actual connectors would be blown.

Assuming you have a 6 pin, FIreWire 400 port, you could check pin 1 (30 V unregulated) and see if there's anything there. That line would feed both ports and if it blew there's a good chance your FireWire device may not be visible, even though (I assume) you external drive is not self powered.

If you're a soldering "dare devil" you could open the unit up, look at the logic board, and look at the traces to see if one is blown. Do keep in mind, however, that what I'm providing you are educated guesses.

Or, of course, you could just put up with USB. :eek:

Regarding FireWIre vs. USB, FireWire is peer-to-peer technology, whereas USB 2.0 is master-slave. Here's a link briefly describing the differences:

Distributed, Modular Control: Peer-to-Peer vs. Master/Slave

Keep in mind that there are plenty of slow USB devices like keyboards and mice that may all be sharing the same "master." Have you ever heard of a FireWire keyboard?

I was really ticked off a few years ago when it appeared FireWire was going the way of the Do-Do bird in what appeared to be a USB-only model, but then came Thunderbolt to the rescue.
P Jan 30, 2013 03:34 AM
Quote, Originally Posted by D R Turbo (Post 4214382)
Regarding FireWIre vs. USB, FireWire is peer-to-peer technology, whereas USB 2.0 is master-slave. Here's a link briefly describing the differences:

Distributed, Modular Control: Peer-to-Peer vs. Master/Slave

Keep in mind that there are plenty of slow USB devices like keyboards and mice that may all be sharing the same "master." Have you ever heard of a FireWire keyboard?

I was really ticked off a few years ago when it appeared FireWire was going the way of the Do-Do bird in what appeared to be a USB-only model, but then came Thunderbolt to the rescue.
Tangential, but it might be worth noting: There is another factor that is more important in HD performance over USB and Firewire than the peer-to-peer thin . USB implements storage over something called BOT, Bulk Only Transfer. As storage protocols go, this is a very inefficient way of transferring things, because you have to wait for one block to be completely transferred before sending the next. Firewire, on the other hand, has a dedicated storage protocol (SBP).

Fortunately USB 3.0 does something about this. There is an optional part of the standard called UAS for USB-attached SCSI, which implements the SCSI protocol on top of the USB cable, improving things significantly. Note that this is optional, so you'll have to check the quality of the hard drives that you buy with USB 3.0, but at least you have the option.
BWilliams Feb 4, 2013 10:00 PM
Here's an update for you guys:

Resetting the SMC as Spheric Harlot suggested looked like an easy thing to do, so I did it. I expected nothing. I plug in the FireWire drive (with a different cable) and guess what? IT SHOWS UP!!

WOW! I thought. It's fixed. It just needed a reset! Then I thought to myself, "Well, wait a minute, lets try the other port too and make sure it's up." I unmount the FireWire drive, power it down, plug it into the other port, power it on and NOTHING!

I thought to myself, "OK, you've got a single blown port, but I can live with that." I proceed to turn off the drive, plug it into the other port (the one that was good) BUT NOW IT'S NOT VISIBLE ANY MORE.

OK, I decide to shutdown, do an SMC reset, and power everything up again with the FireWire unit plugged into the good port. The FireWire drive in the port is now visible and the volumes are like normal.

The following is repeatable:

1. If I plug the drive into the "bad" port, all FireWire ports are disabled and no FireWire devices are seen.

2. If I do an SMC reset, the one port that does work will come back to life and be usable.

I think D R Turbo's theory about it being an internal intermittent short that's completed itself and is now a permanent short is correct. If the unit is plugged into this now bad port and I try to use the system, it acts squirrelly. It takes about 3 minutes to boot, EVERYTHING is running as slow as molasses. If I shut down, do the SMC reset, plug the drive into the "good" port then the system is like nothing was ever wrong with it.

What I'm going to do this weekend is probably open the unit up and see if I can find something that might be making this thing short out. Possibly the other FireWire port can be revived too if I find it, but I'm not holding my breath - I only need one port working anyway.

This has been one of these types of problems: -----> :brick:

Thanks for the help guys. Any more tips?
Spheric Harlot Feb 5, 2013 01:47 AM
Always keep a dead chicken and a quart of animal blood around when dealing with digital voodoo.
BWilliams Mar 6, 2013 12:45 AM now for an update....

I took 2 dead chickens, shook them over the unit, while doing a VooDoo chant. Sorry, no blood available, couldn't do that . NOW IT WORKS!!!

Seriously, I stopped being lazy and opened the unit up. I would suspect there was a short in there because it looks like two connections on some tiny chip near the FireWire port are browned and fused. I knew that burning odor wasn't my imagination.

As long as nothing is plugged into that port, the system doesn't (seem) to have any problems. A Scannerz test now shows none of the bizarre irregularities it was picking up before as long as nothing is plugged into the port. I didn't try any scan with something plugged into the bad port because if I plug any FireWire device into the bad ports, then both ports shutdown, and I have to do an SMC reset to get the one back.

The correct engineering solution in this case appears to be to put a piece of tape over the bad FireWire port.:P least I don't have to use USB for a bootable device! ;)
ghporter Mar 6, 2013 06:58 AM
What is probably happening is that the "bad" port pulls too much current when you plug something into it, and the system shuts down the entire FireWire system in response. When you reset the SMC, it resets the FW system...until that one port pulls too much current.

You are correct at this point in stating that the correct engineering choice is to tape over the bad port to prevent your using it. (I need to reset my own SMC to see if that resets my FW system...) The ultimate fix is, if your 2006 iMac is built like my 2007 iMac, to replace the FireWire daughter board. Which I hope not to need to do, especially if the SMC reset works.
BWilliams Mar 7, 2013 04:41 AM
I wish that was the problem. On the 2006 model I have there's sort of a plastic "connection box" (for lack of better words) that looks like it's glued onto the logic board. It would make no difference because the blown area is on the logic board itself that looks like it's feeding into it. I think the box is probably nothing more than a connector extension, which is a guess.

As another point, I suppose it's possible what I think is the blown area may not be a chip, but possibly something like a resistor block. I really should have gotten out a magnifying glass and looked at it, but it was working as is and I was really looking for something "running around" in there (like a loose screw or a piece of wire thread). I only need one FireWire port anyway since all the FireWire devices I have can be daisy chained.
ghporter Mar 9, 2013 05:59 PM
Just because a part looks "toasty" doesn't mean it has been damaged. This is very important; while in most cases it is THE faulty part that gets browned by too much heat, it is sometimes just an "innocent bystander" and the real faulty part is something like a broken connector. It is possibly an expensive fix, but having that looked at will at least save you from some worry about what might fail next.

And to update, resetting my own SMS fixed my "both firewire ports are bad" problem.
BWilliams Mar 9, 2013 11:41 PM
To re-iterate, if I reset both the ports, they're still active, or I think they are. If I plug into the "good" port, there's no problem. If I plug the FireWire into the "bad" ports, both ports go down and I have to reset it again. I'm not sure if you missed that or not. The port can still, somehow get electricity. I suspect your theory about the bad port pulling too much current is correct. It makes perfect sense.

As long as everything is working OK I'm going to leave it alone. Opening that unit up was, at least for me, a PIA. If further problems develop I'll likely just get another system. Everything seems to be working just fine now, though.
ghporter Mar 10, 2013 01:19 PM
I caught all of it. If you plug into the bad port, which probably has something wrong with the connector, you will draw too much current and the whole FW system will shut down to protect the computer, and the burnt-looking spot on the board is probably due to the previous overcurrent.

I wasn't suggesting that you needed to have the machine looked at now, but rather if you had additional problems related to your FireWire ports. As you say, replacing the computer is probably a better choice if you can afford it.
reader50 Mar 10, 2013 02:02 PM
It's possible the bad port will still work as a data-only port. You'd need a 6 -> 4 adapter and something that takes a 4-pin FW input. Or another 4 -> 6 adapter to bump it back to a full-sized FW400 port.
All times are GMT -4. The time now is 02:20 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

Content Relevant URLs by vBSEO 3.3.2