MacNN Forums (
-   macOS (
-   -   Booting off external drive - Need to reboot twice (

Eug Feb 26, 2012 12:49 PM
Booting off external drive - Need to reboot twice
Well, this is odd. On my 2010 i7 iMac if I hold down the OPTION key to reboot I do get the list of attached external drives. However, if I select any of the drives, it won't reboot. It will just select it, and stay there. Nothing else happens. If I click on the arrow button, it just sits there. If I press the return key, it just sits there. (See pic below for the screen I'm talking about. That's a pic from Apple, not my iMac, but the result is the same.) Also, after I select a drive, I can't select any other drive. It's locked to that drive I selected.)

However, after that drive is selected, if I shut the computer off and then reboot again, it boots the drive I selected the last time. This is consistent. I tried this several times, including after resetting the PRAM.

BTW, my Bluetooth Magic Mouse won't work either, but a wired one will.


P.S. I wasn't entirely sure where to put this, so I put it here. Please feel free to move if you think it's more appropriate elsewhere.
Eug Feb 26, 2012 03:28 PM
I just tried this on my MacBook Pro with the same external drive. It works fine.

However, the boot menu screen on my MacBook Pro is different. My MacBook Pro's menu looks like the picture above. However, for my iMac (mid-2010 iMac 11,3) , it has the added wireless option:

I think the boot problem may be a firmware issue.

BTW, I tried the same drive with Firewire and with USB, with the same result. Another drive with USB also gave the same result.
Eug Mar 9, 2012 12:05 AM
Has anyone experienced this before? If so, which model machine?

Who else has this screen with the "Choose Network" firmware?
reader50 Mar 9, 2012 12:39 AM
Try resetting PRAM. It sounds like the selection takes, then the firmware hangs trying to start the boot.

Actually, it sounds like bug in your firmware, but there's not much we can do about that. You probably can't reapply the latest firmware update. So I'd suggest PRAM reset. Followed by SMU reset if it still glitches. Then ... genius bar?
Eug Mar 10, 2012 05:17 PM
Already tried resetting the PRAM, several times. Didn't help.

It does sound like a bug in my firmware, doesn't it? And I think it could be causing my login delay issue as well. For some reason I can't log myself into my user account until after a minute delay. However, if I put that same Lion install on an external drive and try it on my MacBook Pro, I have neither the boot problem nor the login problem.

So, I'm going to contact Apple Care. This is going to be a major pain to take in. First off it's a 27" incher but additionally I have to remove it from the VESA mount and reattach the regular mount. In addition, I'll have to remove the extra RAM I installed (same RAM Apple uses).
Eug Mar 11, 2012 11:21 AM
Arrgghh. Reset the NVRAM again, and this time it wouldn't boot into anything. It just hung at a blank gray screen (no Apple logo). So if I boot with the option key, it brings me to the list of drives, but with the same delays. If I select my boot drive then reboot, then it works.

Could there be any issue with the internal drive that's causing this? It's a drive that I had partitioned into two partitions, and then installed Snow Leopard --> Lion on one partition.

Or perhaps the firmware is just permanently borked.
P Mar 11, 2012 12:19 PM
I think your firmware has been corrupted somehow, so AppleCare is likely required at this point.
Art Vandelay Mar 11, 2012 12:47 PM
A failing hard drive will also cause those symptoms.
Eug Mar 11, 2012 08:28 PM
Finally figured it all out. It was an incompatibility with my Firewire DVD burner. Very strange. I think somehow it was causing my my NVRAM to get corrupted, but when I would unplug the drive to troubleshoot, things would remain borked (because the NVRAM was still corrupted). If I tried to reset the NVRAM with the drive plugged in, the reset wouldn't work, and things would still be borked.

I had reset the NVRAM many times before, but I guess I hadn't unplugged this particular innocent looking drive when I had done the reset. I guess I had thought I had ruled out this drive as the culprit, because unplugging it (I guess without resetting the NVRAM) made no difference.

I can still use the drive though. I can either use my other Firewire enclosure (which is compatible), or my USB enclosure. FINALLY! I'm glad I picked up that last IDE USB 2 enclosure a few months ago, before they disappeared completely. They're all SATA these days. (I keep this old drive because it's region free and sets the bit to emulate DVD-ROM, for DVD+R discs.)
All times are GMT -4. The time now is 07:13 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

Content Relevant URLs by vBSEO 3.3.2