MacNN Forums (
-   macOS (
-   -   MacCrash None Others Permission Issue (

FIZZLE Apr 11, 2013 07:51 PM
MacCrash None Others Permission Issue
Hello Everyone, Can anyone helped me pleeeeeeease?

I just learned how to crash my mid-2007 Black Macbook by switching ''Others'' ''Read Only'' permissions to ''None'' via the Mac HD Info window after foolishly presuming that it might avoid the machine being hacked due to a Yahoo account of mine having been hacked recently.

I've been going round in circles for the past few days trying to figure how to re-set the 'Others' permissions back and have gone through all the standard procedures I could find but kept getting the same outcome, i.e,

The machine boots chimes then a grey screen displaying the apple icon appears
then the screen turns blue and the wheel turns round - then disappears for a second - then comes back again and endlessly repeats like it's stuck ...?

I've tried booting from the orig install disc (Leapard OSX 10.4) and neither that or re-setting the perimeter ram or booting in safe mode or trying to boot the macbook in Target mode to boot from my (pre intel) G5 tower - via fire wire worked. Just keep getting the Grey/apple icon screen then the blue screen and turning wheel.

Today I found this excellent (macnn) site and a discussion about the problem I'm experiencing


While I was trying to get my head round the discussion and unix code - I thought I should try removing one of the 1GB ram chips from the black macbook to check if that made any difference?

I removed a 1GB ram chip, put the battery back, then I started up the macbook and after the chime I pressed: option control s the screen turned black and what I think is called the terminal or the shell window appeared and white text scrolled down the page -

yippee signs of life:)

can anyone advise what I should type to cause the ''Others'' option to revert back to

''Others Read Only'' Please?

The Black Macbook is running Leapard OSX 10.5.8 (after updates etc)

Spheric Harlot Apr 12, 2013 05:11 PM
Just pressing and holding "s" upon boot chime should bring you to that black screen with the white text, a.k.a. Single User Mode.

When you're there, type

mount -uw /
And hit return (there's a single space before the slash; it's important.

then type

chmod o+r /
and hit return.

That should do it.
All times are GMT -4. The time now is 11:23 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

Content Relevant URLs by vBSEO 3.3.2