MacNN Forums (
-   macOS (
-   -   Partitioning error on 10.5.8/Leopard (

ValVashon Dec 26, 2013 04:23 PM
Partitioning error on 10.5.8/Leopard
Today's patient is my son's MDD G4, dual 1 GHz running 10.5.8. Hard drive size is 40 GB. Since I can't find Java 6 to allow us to run the game Minecraft, I have decided to jump into the world of Linux with Ubuntu 12.04, which is on a CD and ready to load. To do that I need to partition the hard drive and that's where the problem is. Here is a screen grab of the error message I get:

"Filesystem resize support required, such as HFS+ with Journaling enabled"

In my administrators account, I click the "+" button and get two partitions as shown. "A new volume will be created" and the OSX volume will not be erased. The only option I get for format is "Mac OS Extended (Journaled). I hit "Apply" and almost immediately get that error message. I have tried resizing the new partition and also renaming it but still get the error. I even tried doing this after booting off of the system disc but still get the error message.

I could boot off of the system disc, erase the drive and reformat with two partitions but don't want to reload the OS and all the updates, etc. I did do a Time Machine backup but don't know how or if that will restore the OSX system to what was on their before but on 1/2 of the disc (1/2 would still be plenty of room for the install of Leopard that is on here). How Time Machine works is a bit of a mystery.

I could also get a second hard drive but don't know how to set up the jumpers to allow for option booting.

Best and easiest would be to partition in place as I am trying to do- does anybody know how to get around this error message?


BLAZE_MkIV Dec 27, 2013 02:01 AM
Don't even bother if it's for minecraft. That computer won't be able to handle it I'm afraid.
P Dec 27, 2013 08:12 AM
Many ways to do this, but first: did you try enabling journaling? Just select the partition and select that option from the File menu.

Java 6 for PPC exists as a beta, but apparently is hard to find. Shifuimam has been chasing it, but I don't think it ever turned up.
All times are GMT -4. The time now is 03:14 PM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

Content Relevant URLs by vBSEO 3.3.2