MacNN Forums (
-   Networking (
-   -   MacBook connection timeout with hotel Wifi only (

trishacupra Jun 24, 2013 03:09 AM
MacBook connection timeout with hotel Wifi only
I'm having a "Connection Timeout" issue while trying to connect to my hotel's WIFI.

I bought an ex-lease refurbished white MacBook (Build 12E55 – 2.4GHz, the last 2010 model I think) a couple of weeks ago. I bought it so I could use it while on vacation in Bali, Indonesia. I've got OS X 10..8.4 installed.

At home in Australia, this MacBook connected to my home WIFI with absolutely no issues at all.

Now that I'm in Bali, I'm surprised to find that every time I try to connect to the WIFI at the hotel (where I'm staying for a whole month), I get a "Connection Timeout" error. I'm surprised because my iPhone connects to the hotel WIFI with no problem at all, as does our two iPads and the Android phones that belong to other family members. It's only my MacBook that struggles, even though I get even better signal strength indicated on my MacBook compared to my other devices.

I can connect my MacBook to my iPhone hotspot fine, though I'd prefer to use the free hotel WIFI over my very small 3G data allowance.

So the problem isn't that my MacBook can't connect to any WIFI, because it did at home and it still can to my iPhone hotspot.

And the problem isn't with the router, because all other devices work flawlessly.

I've trawled many forums and articles trying to find a solution. Here's everything I've tried already, that I can remember. (Not in this order and not all at once.)

Rebooted MacBook (duh)

Sitting directly under the WIFI router. (It's not a signal strength issue.)

Set up new Network > Location. Deleted Ethernet and Bluetooth PAN so it's just WIFI in the list.

Renewed DHCP Lease countless times.

Tried manual TCP/IP variations. It doesn't help that I'm not sure what to put in the IPv4 Address field. I do know the Subnet Mask and Router IP from looking at my iPhone network info.

Tried using my MAC address as the DHCP Client ID. Also tried just using "1" or leaving it blank.

I don't know what an IPv6 is either.

Tried BootP and completely Manual setups but not really sure of the correct settings to try.

Tried using the DNS servers that I found on my iPhone network info for the hotel WIFI. (One of them is which I think is Google's DNS thing?)

Tried checking Auto Proxy Discovery and Use Passive FTP Mode, since it was suggested as part of a solution in a forum thread.

Tried changing the MTU to a couple of other settings from an article I read. I think one was around 1453 and the other was 1494 or something close to that.

Tried resetting PRAM

Tried resetting SMC

Tried a variation on resetting SMC that involved pressing down the normal keys plus one extra, for 10 secs, since it worked for someone who was told to do that by an Apple Care person. (He didn't know why it worked and other forum posters thought it was supposed to have been a SMC reset.)

Checked the Network> Wi-Fi in System Information to see if the Channel is compatible. The router uses Channel 1 and my MacBook is capable of using Channel 1.

Checked my country profile. It's X1. I have no idea if that's good. All I know is that I'm in Indonesia not Australia and I'm having WIFI issues with this hotel network.

Checked the PHY Mode. Supported are 802.11 a/b/g/n. The hotel router uses 802.11n.

Made sure I was using WPA2 Personal.

Tried deleting all WIFI-related passwords in Keychain.

Tried deleting all Network-related preference files.

Tried removing all LaunchDaemons and LaunchAgents.

It's not a "lost WIFI connection when waking from sleep" issue but I tried turning off sleep anyway.

My husband even had the nerve to unplug the hotel router (small hotel, we're the only guests at the moment) for 10 minutes hoping it will reboot. But I don't know if that's the actual modem or just a WIFI repeater thing (sorry, can't remember the right terms). It didn't work anyway.

I've run out of options, other than just sucking it up and getting a big 3G data allowance since I'm here for a month.

If there is anything else I can try – perhaps working out how to set up my Network manually properly, please help me out. Here is everything in System Information that might help. I'll happily provide any other info.

Software Versions:
CoreWLAN: 3.3 (330.15)
CoreWLANKit: 2.0.2 (202.10)
Menu Extra: 8.1 (810.9)
configd plug-in: 8.4 (840.22.1)
System Information: 8.3 (830.5)
IO80211 Family: 5.3 (530.4)
Diagnostics: 2.0 (200.24)
AirPort Utility: 6.3 (630.34)

Card Type: AirPort Extreme (0x14E4, 0x93)
Firmware Version: Broadcom BCM43xx 1.0 (
MAC Address: [omitted]
Locale: APAC
Country Code: X1
Supported PHY Modes: 802.11 a/b/g/n
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 149, 153, 157, 161, 165
Wake On Wireless: Supported
AirDrop: Supported
Status: Not Associated

Local Wi-Fi Networks:
Puri Hasu Bali:
PHY Mode: 802.11n
BSSID: [omitted]
Channel: 1,+1
Network Type: Infrastructure
Security: WPA/WPA2 Personal
Signal / Noise: -92 dBm / -92 dBm
ibook_steve Jun 24, 2013 10:54 AM
Wow. You've been busy.

Is it one of those public routers where you have to go to a web page to authenticate? Are you saying this web page does not pop up on your computer? This is what usually happens if you can connect to the wifi but then can't get anywhere.

Can you ping the router or anywhere else when you try to connect? From Terminal, just try "ping x.x.x.x" or "ping".

Are you getting a valid IP address when you use DHCP, not a 169 IP?

I can't think of anything else that you haven't tried.

trishacupra Jun 25, 2013 03:25 AM
Yep. Tried everything I found.

No, not the type where a web page comes up. You just connect by choosing the network and putting in the password. But when I put in the password (even if I try a wrong one) it goes straight to a Connection Timeout even though it only tries for a few moments. (If I put a wrong password in, it has a connection timeout before even realising the password is invalid.)

Very frustrating.
trishacupra Jun 25, 2013 03:28 AM
Oh, and since I never get past the password prompt I can't ping anything and no IP or anything comes up in the DHCP settings at all.

It's like it hits a brick wall before it even considers whether the password is valid. And yet the signal strength is showing as stronger than any other device I have.
trishacupra Jun 25, 2013 03:32 AM
All ideas welcome. :)
Waragainstsleep Jun 26, 2013 04:33 AM
Go to Applications -> Utilities and fire up the Console app.

Set it to display all messages and then try to connect to the wifi network again. Keep an eye for anything relevant in the console log and if it doesn't immediately suggest an answer to you, copy the relevant lines and post them here and we'll take a look for you.
Waragainstsleep Jun 26, 2013 04:35 AM
I don't suppose there is a spare ethernet port on the wifi box? Is it connected to the hotel network via ethernet? Perhaps you could "borrow" that connection and plug it into your MacBook for a quick test. Not sure what it would tell you though...
trishacupra Jun 26, 2013 09:30 PM
It's the strangest thing. I opened up Console, attempted the connect - and it actually did. Then I closed the lid, moved a couple of metres away, and had trouble reconnecting after that very short 'hibernation'. But turning my wifi on and off brought it back.

Maybe the hotel powered down the modem since I last tried, it maybe its just one more thing that doesn't make sense in the wonderful land of Bali. :-)
Waragainstsleep Jun 27, 2013 03:41 AM
Sometimes you just get one device that won't connect for a while, then it works again. I once spent two days trying to solve such an issue. An office full of Macs and I switched out the modem/router and the Airport base station and still one Mac wouldn't connect, but every now and then it would change which Mac it was. They were nowhere near the user limit either. Never did get to the bottom of that one.
ghporter Jun 28, 2013 06:07 PM
Having issues with reconnecting after a Mac goes to sleep then wakes is something we've all been fighting at one point or another for a long time. Since turning your WiFi off and then back on fixes this for you, I can say pretty clearly that you're seeing this old (and tiring) problem. Essentially, for some reason, the OS doesn't get told that in going to sleep, your Airport card will need to re-synchronize with the network when it wakes up, so it's like the Airport system thinks NO time has elapsed, and it just can't find the network... Hopefully this will help you work around the issue when you see it.
trishacupra Jun 29, 2013 01:35 AM
Yep. Now it's definitely hibernation related. And there's still no way around it after all these years?

Is hibernation the same as Sleep?
ghporter Jun 29, 2013 05:37 PM
Yes, it's the same. Apple uses different terms than Microsoft, but it is essentially the same for both platforms: RAM contents are saved to disk and the machine is all but shut down.

Unfortunately, we've seen the "wake from sleep" issue get "fixed" and then break again from who knows what tweak or re-coding within the Airport system. Some people manage to evade it entirely, but most of us have to find a work-around now and then. At least you know that cycling your wireless off and on reconnects you.
P Jun 30, 2013 05:40 PM
In your Power options, there is an option to allow waking the computer for network access. Try toggling it - sometimes it helps.
Waragainstsleep Jul 1, 2013 08:28 AM
All times are GMT -4. The time now is 03:23 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

Content Relevant URLs by vBSEO 3.3.2