Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > Applications > Handbrake encoding fails

Handbrake encoding fails
Thread Tools
LaurenceB
Banned
Join Date: Nov 2011
Status: Offline
Reply With Quote
Apr 22, 2012, 11:13 PM
 
converting a 1080p MKV to ATV2 format using the latest new release of Handbrake, but is appears to be bombing out of the encode after a few seconds.

any ideas why? (i attached the log)

[10:01:04] hb_init: starting libhb thread
[10:01:04] macgui: Handbrake Version: 0.9.6 x86_64 (2012022800)
[10:01:04] hb_init: starting libhb thread
[10:01:04] hb_init: starting libhb thread
[10:01:04] macgui: hbInstances path to this instance: /Applications/HandBrake.app
[10:01:04] macgui: hbInstance found instance pidnum:36626 at path: /Applications/HandBrake.app
[10:01:04] macgui: hbInstance MATCH FOUND, our pidnum is:36626
[10:01:04] macgui: Pid for this instance:36626
[10:01:04] macgui: HBQueueController : My Pidnum is 36626
[10:01:14] macgui: trying to open video_ts folder (parent directory chosen)
[10:01:14] macgui: Preview: Disabling HUD Controls
[10:01:14] macgui: Minimum length of title for scan: 900000
[10:01:14] hb_scan: path=/Users/media/Desktop/file.mkv, title_index=0
libbluray/bdnav/index_parse.c:157: indx_parse(): error opening /Users/media/Desktop/file.mkv/BDMV/index.bdmv
libbluray/bluray.c:1471: nav_get_title_list(/Users/media/Desktop/file.mkv) failed (0x102110400)
[10:01:14] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdnavVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnavVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[10:01:14] dvd: not a dvd - trying as a stream/file instead
Input #0, matroska,webm, from '/Users/media/Desktop/file.mkv':
Duration: 01:42:44.16, start: 0.000000, bitrate: 1536 kb/s
Stream #0.0(eng): Video: h264 (High), yuv420p, 1920x1080, PAR 1:1 DAR 16:9, 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
Stream #0.1(eng): Audio: dca (DTS), 48000 Hz, 5.1, s16, 1536 kb/s (default)
[10:01:14] scan: decoding previews for title 1
[10:01:14] scan: audio 0x1: DCA, rate=48000Hz, bitrate=1536000 English (DTS) (5.1 ch)
[10:01:15] scan: 10 previews, 1920x1080, 23.976 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[10:01:15] scan: title (0) job->width:1920, job->height:1072
[10:01:15] libhb: scan thread found 1 valid title(s)
[10:01:15] macgui: showNewScan: This is a new source item scan
[10:01:15] macgui: Preview: Enabling HUD Controls
[10:01:47] macgui: Rip: Pending queue count is 0
[10:01:47] macgui: createQueueFileItem: Getting Audio from prepareAudioForQueueFileJob ...
[10:01:47] macgui: createQueueFileItem: Returned getting audio from prepareAudioForQueueFileJob
[10:01:47] macgui: getNextPendingQueueIndex next pending encode index is:0
[10:01:47] macgui: scanning specifically for title: 1
[10:01:47] hb_scan: path=/Users/media/Desktop/file.mkv, title_index=1
libbluray/bdnav/index_parse.c:157: indx_parse(): error opening /Users/media/Desktop/the.muppets.2011.1080p.bluray.x264-sparks.mkv/BDMV/index.bdmv
libbluray/bluray.c:1471: nav_get_title_list(/Users/media/Desktop/file.mkv) failed (0x102270400)
[10:01:47] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdnavVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnavVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[10:01:47] dvd: not a dvd - trying as a stream/file instead
Input #0, matroska,webm, from '/Users/media/Desktop/file.mkv':
Duration: 01:42:44.16, start: 0.000000, bitrate: 1536 kb/s
Stream #0.0(eng): Video: h264 (High), yuv420p, 1920x1080, PAR 1:1 DAR 16:9, 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
Stream #0.1(eng): Audio: dca (DTS), 48000 Hz, 5.1, s16, 1536 kb/s (default)
[10:01:47] scan: decoding previews for title 1
[10:01:47] scan: audio 0x1: DCA, rate=48000Hz, bitrate=1536000 English (DTS) (5.1 ch)
[10:01:47] scan: 10 previews, 1920x1080, 23.976 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[10:01:47] scan: title (0) job->width:1920, job->height:1072
[10:01:47] libhb: scan thread found 1 valid title(s)
[10:01:47] macgui: ScanDone state received from fQueueEncodeLibhb
[10:01:47] macgui: Preset: Custom
[10:01:47] macgui: processNewQueueEncode number of passes expected is: 1
[10:01:47] macgui: Start / Stop set to chapters
[10:01:47] macgui: prepareJob exiting
[10:01:47] 1 job(s) to process
[10:01:47] starting job
[10:01:47] sync: expecting 147816 video frames
[10:01:47] job configuration:
[10:01:47] * source
[10:01:47] + /Users/media/Desktop/file.mkv
[10:01:47] + title 1, chapter(s) 1 to 1
[10:01:47] + container: matroska,webm
[10:01:47] + data rate: 1536 kbps
[10:01:47] * destination
[10:01:47] + /Users/media/Desktop/file.m4v
[10:01:47] + container: MPEG-4 (.mp4 and .m4v)
[10:01:47] + 64-bit formatting
[10:01:47] * video track
[10:01:47] + decoder: h264
[10:01:47] + frame rate: 23.976 fps -> peak rate limited to 29.970 fps
[10:01:47] + dimensions: 1920 * 1080 -> 1280 * 720, crop 0/0/0/0, mod 16
[10:01:47] + encoder: H.264 (x264)
[10:01:47] + quality: 18.00 (RF)
[10:01:47] * audio track 1
[10:01:47] + decoder: English (DTS) (5.1 ch) (track 1, id 0x1)
[10:01:47] + bitrate: 1536 kbps, samplerate: 48000 Hz
[10:01:47] + mixdown: Dolby Pro Logic II
[10:01:47] + encoder: AAC (CoreAudio)
[10:01:47] + bitrate: 160 kbps, samplerate: 48000 Hz
[10:01:47] * audio track 2
[10:01:47] + decoder: English (DTS) (5.1 ch) (track 1, id 0x1)
[10:01:47] + bitrate: 1536 kbps, samplerate: 48000 Hz
[10:01:47] + mixdown: 6-channel discrete
[10:01:47] + encoder: AC3 (ffmpeg)
[10:01:47] + bitrate: 640 kbps, samplerate: 48000 Hz
[10:01:47] reader: first SCR 0 id 0x0 DTS 0
[10:01:47] encx264: min-keyint: 24, keyint: 240
[10:01:47] encx264: Encoding at constant RF 18.000000
x264 [warning]: --psnr used with psy on: results will be invalid!
x264 [warning]: --tune psnr should be used if attempting to benchmark psnr!
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.2 AVX
x264 [info]: profile High, level 3.1
Stream with high frequencies VQ coding
Stream with high frequencies VQ coding
[matroska,webm @ 0x102111c00] Read error at pos. 18671682 (0x11ce842)
[10:02:03] reader: done. 1 scr changes
[10:02:14] work: average encoding speed for job is 16.510355 fps
[10:02:14] sync: got 341 frames, 147816 expected
[10:02:14] h264-decoder done: 341 frames, 0 decoder errors, 0 drops
[10:02:14] render: 341 frames output, 0 dropped and 0 duped for CFR/PFR
[10:02:14] render: lost time: 0 (0 frames)
[10:02:14] render: gained time: 0 (0 frames) (0 not accounted for)
x264 [info]: frame I:3 Avg QP:11.16 size: 43845 PSNR Mean Y:66.68 U:67.66 V:67.94 Avg:67.00 Global:51.32
x264 [info]: frame P:217 Avg QP:16.87 size: 19705 PSNR Mean Y:51.30 U:53.48 V:53.49 Avg:51.89 Global:49.30
x264 [info]: frame B:121 Avg QP:19.43 size: 5689 PSNR Mean Y:55.76 U:57.53 V:58.20 Avg:56.33 Global:49.17
x264 [info]: consecutive B-frames: 40.5% 32.3% 13.2% 14.1%
x264 [info]: mb I I16..4: 39.5% 45.6% 15.0%
x264 [info]: mb P I16..4: 7.0% 8.8% 2.7% P16..4: 45.4% 16.2% 7.6% 0.0% 0.0% skip:12.4%
x264 [info]: mb B I16..4: 0.1% 0.5% 0.2% B16..8: 44.6% 3.5% 0.5% direct: 1.5% skip:49.2% L0:36.6% L1:59.6% BI: 3.8%
x264 [info]: 8x8 transform intra:48.0% inter:80.5%
x264 [info]: coded y,uvDC,uvAC intra: 37.5% 57.9% 29.5% inter: 24.2% 31.9% 3.5%
x264 [info]: i16 v,h,dc,p: 56% 18% 8% 18%
x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 14% 19% 33% 4% 6% 6% 7% 4% 6%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 24% 20% 31% 4% 6% 5% 5% 2% 3%
x264 [info]: i8c dc,h,v,p: 61% 21% 13% 6%
x264 [info]: Weighted P-Frames: Y:10.6% UV:5.5%
x264 [info]: ref P L0: 68.0% 7.6% 17.6% 6.6% 0.2%
x264 [info]: ref B L0: 86.4% 12.9% 0.7%
x264 [info]: ref B L1: 94.7% 5.3%
x264 [info]: SSIM Mean Y:0.9900467 (20.020db)
x264 [info]: PSNR Mean Y:53.011 U:55.031 V:55.274 Avg:53.588 Global:49.269 kb/s:2849.48
[10:02:14] mux: track 0, 341 frames, 5095820 bytes, 2857.95 kbps, fifo 512
[10:02:14] mux: track 1, 669 frames, 335406 bytes, 188.11 kbps, fifo 1024
[10:02:14] mux: track 2, 445 frames, 1139200 bytes, 638.91 kbps, fifo 512
[10:02:14] libhb: work result = 0
[10:02:15] macgui: incrementQueueItemDone there are no more pending encodes
     
mduell
Posting Junkie
Join Date: Oct 2005
Location: Houston, TX
Status: Offline
Reply With Quote
Apr 22, 2012, 11:22 PM
 
[matroska,webm @ 0x102111c00] Read error at pos. 18671682 (0x11ce842)
Something wrong with the input file. Is it a Blu-ray rip or what's the source?
     
King Bob On The Cob
Mac Elite
Join Date: Apr 2002
Location: Illinois
Status: Offline
Reply With Quote
Apr 26, 2012, 05:14 PM
 
Originally Posted by mduell View Post
Something wrong with the input file. Is it a Blu-ray rip or what's the source?
*cough*
/Users/media/Desktop/the.muppets.2011.1080p.bluray.x264-sparks.mkv
I'd say the problem is that the mencoder in Handbrake isn't able to read the file. Sorry dude.
     
mduell
Posting Junkie
Join Date: Oct 2005
Location: Houston, TX
Status: Offline
Reply With Quote
Apr 26, 2012, 08:02 PM
 
Ah yes, your pirated BR rip isn't quite right.
Or there's a bug in HB's MKV decoder. They don't support piracy anyway, so don't bother posting in their forum for a fix.
     
mduell
Posting Junkie
Join Date: Oct 2005
Location: Houston, TX
Status: Offline
Reply With Quote
Apr 30, 2012, 11:37 AM
 
     
ShaQ
Banned
Join Date: May 2012
Status: Offline
Reply With Quote
May 2, 2012, 04:44 AM
 
I'm seeing the same error as the OP since about 2 weeks on my MacMini Lion 10.7.3 with handbrake 0.9.6 and even some of the recent nightly builds.

If it's source related, why is it not repeatable ? It exits at different points throughout the file, but upon retrying a few times, it would eventually finish properly.
Memory leak? cpu limits when competing with other tasks ?

The only thing I can say so far, I haven't seen a short encode on Snow Leopard, using the same handbrake version and the same source files (tried 10 so far on both SL & Lion). Now Im trying some other apps (MacTheRipper, Magic DVD Ripper failed either, Im working on MacX DVD Ripper Pro right now).

However, since Lion was released months, I have successfully encoded 100+ files. Never seen this type of problem. This "dropout" issue is quite recent.
     
mduell
Posting Junkie
Join Date: Oct 2005
Location: Houston, TX
Status: Offline
Reply With Quote
May 2, 2012, 11:23 AM
 
Did you try following the directions in the post I linked to? Does that work around the issue for you?
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 06:03 PM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,