Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Hardware - Troubleshooting and Discussion > Mac Notebooks > ibook ethernet/networking problem... :(

ibook ethernet/networking problem... :(
Thread Tools
jfandem
Junior Member
Join Date: Jan 2003
Location: FL USA
Status: Offline
Reply With Quote
Feb 6, 2003, 01:29 AM
 
Hey guys, i finally got my ibook 800/combo and i love it, but am having a few problems. I use 56k internet but my gf has cable connection, so i bring the ibook over there and use her connection, but when i plug in the ethernet cable to the ibook, it doesnt let me go online, BUT i have to either turn off the ibook, plug the cable in, then turn it back on then it works, or i can plug it in, then restart, and it works that way also. I have also networked it directly to my PC and i had to do the same thing, it didnt work until i restarted/shut down. It seems like any ethernet connection works this way. I have talked to other users and they say this should not be happening, and it happend on my other ibook too (replaced because of software issues/heat) So is there a setting i need to fix? Is it because i also have 56k connection? I have network set on automatic also...thanks!
     
MPC
Dedicated MacNNer
Join Date: Nov 2002
Location: lost on mt. hood
Status: Offline
Reply With Quote
Feb 6, 2003, 03:08 AM
 
You should need to set up two different network locations. One for 56k and one for your cable modem. (DHCP, I assume) After you do this you can easily switch between the two under location in the Apple Menu.
     
jfandem  (op)
Junior Member
Join Date: Jan 2003
Location: FL USA
Status: Offline
Reply With Quote
Feb 6, 2003, 12:27 PM
 
Well i do have two set up already, but i appreciate your reply ,anyone else? Thanks!
     
xtal
Senior User
Join Date: Nov 2002
Location: San Francisco Bay Area
Status: Offline
Reply With Quote
Feb 6, 2003, 12:35 PM
 
You mentioned that you have network set to 'Automatic' right? If this is the case (and correct me if I'm wrong) the network settings for the modem and ethernet connection have to be in the same network settings scheme, under different tabs. Instead of two separate settings as you have them set up now.

Then, the computer will automatically pick which of the two you're connected to (modem or NIC) and will give you a connection that way.


To choose doubt as a philosophy of life is akin to choosing immobility as a means of transportation.
     
halcyondays
Fresh-Faced Recruit
Join Date: Dec 2002
Status: Offline
Reply With Quote
Feb 7, 2003, 04:09 AM
 
You might want to look at what additional software your internet company made you install on your iBook. My university used a CISCO VPN client to authenticate all log-ons for security purposes; unfortunately it meant that my iBook was, like yours, unable to recognise LAN new connections without a reboot. In fact if I so much as unplugged a connected cable and put it right back in, I would lose the IP and have to reboot.

Unfortunately there was no workable solution - I sacrificed the usage of the school ethernet network and deleted the whole VPN client. Hope it doesn't come to that for you.
     
Macpilot
Mac Elite
Join Date: Jan 2002
Location: California
Status: Offline
Reply With Quote
Feb 13, 2003, 01:25 AM
 
I have a cable modem hooked up to my Power Mac. When I first got my iBook and needed to do all those software updates, I chose to hook it up to the cable modem directly instead of the Aiport; much faster.

Anyway, my experience with cable modems is that you might try just unplugging the power from the cable modem. Then plug in the iBook to it. After a few seconds, plug the cable modem back in. What happens is the modem gets a new IP address for this new computer. There should be NO setup required. As long as ethernet is active in your Network Preferences, you don't need to do anything else to get the iBook to recognize the cable modem.

This also happens to my PS2 when I hook it up to the cable modem via the network adapter. If I try just disconnecting the Power Mac ethernet cable from the modem, and swapping the PS2 cable, the connection is lost.

Next time you hook up to your girlfriend's modem, try it! Good luck.
MacBook Pro
Mac Mini
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 02:48 AM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,