Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > macOS > Clock problems creating major headaches

Clock problems creating major headaches
Thread Tools
kumarp
Fresh-Faced Recruit
Join Date: Nov 2009
Status: Offline
Reply With Quote
Nov 16, 2009, 01:36 PM
 
First time posting. Thanks for reading.

Here is a screenshot from my AIM discussion this morning:



That weird ongoing discrepancy in times (easily viewed in AIM, where it alternates between the two) is wreaking havoc. Even though the time on my desktop is always correct, when I send an email, it is invariably the "wrong" time, causing it to often get buried in recipients' inboxes. More importantly, I can't properly sync my iCal with my iPhone, because the time thing screws up all the appts on the phone (interestingly, they stay correct on my computer, meaning that my "sync" isn't functioning as a real "sync"), even sending them to the wrong day. It's starting to do weird stuff with old sent AIM messages as well, making it seem to people who actually got them days ago like I just sent them.

I have Leopard 10.5.8 on a mac mini, and I'd prefer not to have to purchase Snow Leopard just to deal with this.

Incidentally, there's very little info that I can find on the internet about this, but this old thread from this forum seems to address the same problem:

http://forums.macnn.com/90/mac-os-x/...lock-problems/

Please help if you can. Thanks.
( Last edited by kumarp; Nov 16, 2009 at 03:04 PM. Reason: added 10.5.8 to title of post for clarity)
     
Dork.
Professional Poster
Join Date: Sep 2005
Location: Rochester, NY
Status: Offline
Reply With Quote
Nov 16, 2009, 03:24 PM
 
Is the problem that the system time is off, or that somehow you have applications that aren't using the system time correctly?

The problem in the thread you linked to is the fact that Mac OS X, like a proper UNIX, sets its system clock to be set to UTC, and deals with timezone offsets and DST for your local time in the OS. While Windows likes to set the system clock to the local time. So if you do a lot of going back and forth between Mac OS X and Windows, you will have to tell one of the OS's to stop mucking with the clock. I don't think that's your problem, but please let us know if you have Windows installed on your Mini.

I'm not at a mac right now, but somewhere in a control panel (Date and Time, perhaps?) you ought to find the controls for the timezone and automatic time syncing to NTP. Do you have the right timezone selected?

Which NTP server is being used? It might be possible that the process of syncing to NTP is screwing you up, but I doubt it. You can try setting the clock yourself, which I think is sufficient to stop NTP from updating your clock.
     
kumarp  (op)
Fresh-Faced Recruit
Join Date: Nov 2009
Status: Offline
Reply With Quote
Nov 16, 2009, 03:48 PM
 
Originally Posted by Dork. View Post
Is the problem that the system time is off, or that somehow you have applications that aren't using the system time correctly?
System time. Applications seem to be responding accordingly.

Originally Posted by Dork. View Post
The problem in the thread you linked to is the fact that Mac OS X, like a proper UNIX, sets its system clock to be set to UTC, and deals with timezone offsets and DST for your local time in the OS. While Windows likes to set the system clock to the local time. So if you do a lot of going back and forth between Mac OS X and Windows, you will have to tell one of the OS's to stop mucking with the clock. I don't think that's your problem, but please let us know if you have Windows installed on your Mini.
I use VMware to access Windows very occasionally. Definitely not on a majority of the time.

Originally Posted by Dork. View Post
I'm not at a mac right now, but somewhere in a control panel (Date and Time, perhaps?) you ought to find the controls for the timezone and automatic time syncing to NTP. Do you have the right timezone selected?
When I select the right time zone, it does this for some reason:



The time on my desktop is still correct, but you can see my computer's confusion right there.

Originally Posted by Dork. View Post
Which NTP server is being used? It might be possible that the process of syncing to NTP is screwing you up, but I doubt it. You can try setting the clock yourself, which I think is sufficient to stop NTP from updating your clock.
The way I got it to at least show the correct time on the desktop was by manually setting the clock myself, but that hasn't stopped the other problems.
     
kumarp  (op)
Fresh-Faced Recruit
Join Date: Nov 2009
Status: Offline
Reply With Quote
Nov 16, 2009, 03:49 PM
 
By the way, thanks Dork!
     
Dork.
Professional Poster
Join Date: Sep 2005
Location: Rochester, NY
Status: Offline
Reply With Quote
Nov 16, 2009, 04:02 PM
 
Where in the world are you? What is your time zone offset?

If you manually set the computers clock, and listed time zone is correct, do you still have other problems?
     
kumarp  (op)
Fresh-Faced Recruit
Join Date: Nov 2009
Status: Offline
Reply With Quote
Nov 16, 2009, 05:24 PM
 
I'm in Ukiah, CA (Pacific Time)

Yeah, it's weird: I still have problems even with the clock manually set to read correctly. For instance, I just received an email at 9 pm tonight, even though it's actually 1:30.

It seems like a small thing, but all these weird little effects actually can cause stress in some big ways at times.
     
imitchellg5
Posting Junkie
Join Date: Jan 2006
Location: Washington + Colorado
Status: Offline
Reply With Quote
Nov 16, 2009, 10:03 PM
 
Try option-shift-k while the iChat window is open, it resets the time code.
     
kumarp  (op)
Fresh-Faced Recruit
Join Date: Nov 2009
Status: Offline
Reply With Quote
Nov 17, 2009, 01:56 PM
 
Originally Posted by imitchellg5 View Post
Try option-shift-k while the iChat window is open, it resets the time code.
Thanks. I wanted that to work, but it didn't.

Again, I think this is a system thing much more than an application thing. Long term, the worst effect is definitely going to be the errors between the iCal on my desktop, and the one on my iPhone. For instance, I have a meeting every month on the 3rd Thursday from 8:30 am to 10 am. My desktop iCal reflects this properly. However, despite syncing other information on the calendar just fine, I can't get it to be right in my iPhone, which says that the meeting is at 12:30 am. I'm actually lucky in this example- at least it's got the day right. Other meetings/deadlines get time-shifted enough that they appear on the wrong day.
     
Dork.
Professional Poster
Join Date: Sep 2005
Location: Rochester, NY
Status: Offline
Reply With Quote
Nov 17, 2009, 08:37 PM
 
Why don't we go back to some basics here. Open up a terminal prompt, and try these commands:

(Type the things inside the angled brackets <>)

<date> will give you the current 24-hr local time.

<date -u> will give you the current 24-hr UTC time.

<date +%z> will give you the current timezone offset, in hours and minutes.
for CA, it should read -0800 (-8 hrs), and the UTC time should be 8 hours "ahead" of the local time.

If all that checks out, then I think that means you system time is configured correctly. If not, you might want to play with the Control Panel and see how your changes affects things on the command line.
     
kumarp  (op)
Fresh-Faced Recruit
Join Date: Nov 2009
Status: Offline
Reply With Quote
Nov 18, 2009, 04:28 PM
 
kumar-plochers-mac-mini:~ kumarp$ date
Wed Nov 18 12:18:49 UTC 2009
kumar-plochers-mac-mini:~ kumarp$ date -u
Wed Nov 18 12:18:58 UTC 2009
kumar-plochers-mac-mini:~ kumarp$ date +%z
+0000
I feel like I've already tried everything at the date and time control panel. It's off by the exact 8 hours, so that seems simple. I go into "Date and Time" and see that under "Time Zone", it has "GMT" selected. Easy enough to change. I select "San Francisco- Pacific", and it changes my manually-corrected time to be incorrect. I correct it (even though now that "clock face" problem shown upthread is happening again) and "lock in" my changes. I go check AIM and emails. The problem persists. I go back to terminal, and it still spits out the same stuff. I go back into "Date and Time" and even though the lock is locked, the "Time Zone" has gone back to "GMT".



Wait, I'm beginning to see something I didn't notice before. The AIM time is only wrong on incoming IMs. Not sure if that's helpful. Also, in mail, the time stamp on my "sent" emails are correct, and the time stamp on my received emails are incorrect. Of course, this is how it appears on my computer. It's worth remembering that people receiving my "sent" emails have complained that the time stamp is way off.
( Last edited by kumarp; Nov 18, 2009 at 05:41 PM. Reason: clarification)
     
Warhaven
Dedicated MacNNer
Join Date: Jul 2002
Status: Offline
Reply With Quote
Nov 18, 2009, 06:16 PM
 
Is the time fubar under a new account? We can at least narrow down if it's a local setting or system wide issue.
     
kumarp  (op)
Fresh-Faced Recruit
Join Date: Nov 2009
Status: Offline
Reply With Quote
Nov 18, 2009, 06:39 PM
 
Originally Posted by Warhaven View Post
Is the time fubar under a new account? We can at least narrow down if it's a local setting or system wide issue.
Yes it is. I logged out and logged in as another account. Opened up AIM and saw the wrong time as soon as I was IM'd.

Thank you for the suggestion though. I know that if I install Snow Leopard, there's a decent chance this goes away, but I don't have a single other reason to install Snow Leopard right now, and that's a lot of dough to pay for solving this problem.

So I really appreciate all the help. Keep it coming!
     
Dork.
Professional Poster
Join Date: Sep 2005
Location: Rochester, NY
Status: Offline
Reply With Quote
Nov 18, 2009, 09:38 PM
 
The timezone setting for your system is obviously borked. Even though the Control panel thinks it's set correctly, it's not set correctly as far as the system is concerned. This explains why some of your incoming E-mails and AIM chats are off, as well: those apps probably ask the system for the UTC and calculate offsets themselves, and your system's UTC is incorrect. (GMT just happens to be the timezone with no UTC offset, btw...)

Anyway, I found this, maybe it will help? The actual timezone is set by making a symbolic link from /etc/localtime to one of the timezones in /usr/share/zoneinfo. If the permissions on /etc/localtime are screwed up, then your applications may not have access to the local timezone information....
http://www.keiths-place.com/blogs/ke...oblem-mac-os-x
( Last edited by Dork.; Nov 18, 2009 at 09:53 PM. )
     
kumarp  (op)
Fresh-Faced Recruit
Join Date: Nov 2009
Status: Offline
Reply With Quote
Nov 19, 2009, 06:18 PM
 
BY JOVE, I THINK THAT DID IT!!!!!

Thank you. Paypal'd the guy some beer money.
     
Dork.
Professional Poster
Join Date: Sep 2005
Location: Rochester, NY
Status: Offline
Reply With Quote
Nov 19, 2009, 07:39 PM
 
Great!
     
lexapro
Baninated
Join Date: Mar 2008
Status: Offline
Reply With Quote
Dec 6, 2009, 01:06 AM
 
You're welcome.
     
pcryan5
Mac Enthusiast
Join Date: Mar 2006
Location: Vancouver, BC
Status: Offline
Reply With Quote
Dec 30, 2009, 07:51 PM
 
FWIW - my Mac Air's time zone kept resetting to GMT. This fixed it.

"Use the Finder's "Go to Folder..." command to open the /etc folder and drag the localtime folder to the trash. You will need to authenticate as an admin to do this. Then just open System Preferences and set Date and Time settings."
Apple - Support - Discussions - Time zone stuck on GMT ...
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 06:38 PM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,