Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > Applications > Word to Mail copy text

Word to Mail copy text
Thread Tools
hab
Forum Regular
Join Date: Mar 2002
Location: San Francisco
Status: Offline
Reply With Quote
Mar 9, 2010, 02:59 PM
 
When I copy text from MSoft Word to Apple Mail, the text always comes over with an extra line space after each paragraph - instead of just one line return, I get two. So, to get the equivalent formatting in the email as I see in the Word document, I have to go into the email and delete a line after every paragraph.

I have the current version of MSoft Office (v.12.2.3) and Snow Leopard (10.6.2).

This is not a big deal but just a nuisance. Do others see this behavior or is this a setting on my end that can be changed? Many Thanks.
21.5" iMac 2.7GHz i5; 15" FP iMac 0.8GHz G4, iPhone 5S
     
is not
Mac Enthusiast
Join Date: Dec 2007
Status: Offline
Reply With Quote
Mar 9, 2010, 04:12 PM
 
No problem here, sorry can't help you.

Mac OS X Leopard (10.5.8)
Office 2004 (11.5.0)
Times New Roman font
     
ibook_steve
Moderator
Join Date: Oct 2001
Location: San Jose, CA
Status: Offline
Reply With Quote
Mar 9, 2010, 08:30 PM
 
Stupid question: are you copying over an extra carriage return? If you are, of course you're going to see it in Mail. Turn on the viewing of invisible markers in Word (the little paragraph symbol in the toolbar). When you select text to copy, make sure you're not selecting the paragraph marker.

Steve
Celebrating 10 years and 4000 posts on MacNN!
     
hab  (op)
Forum Regular
Join Date: Mar 2002
Location: San Francisco
Status: Offline
Reply With Quote
Mar 10, 2010, 03:02 PM
 
I am confused by your remark. Yes there is a paragraph mark at the end of every paragraph that is standard for Word documents. How can you copy a few paragraphs of text without copying the paragraph mark? Without the paragraph demarcation, wouldn't the text be one continuous paragraph?

Here is what happens (with "PP" standing in for the Word paragraph mark)

In Word:

Item1.PP
Item2.PP
Item 3.PP

Copy and Paste into Mail and see:

Item1.

Item2.

Item3.
21.5" iMac 2.7GHz i5; 15" FP iMac 0.8GHz G4, iPhone 5S
     
turtle777
Clinically Insane
Join Date: Jun 2001
Location: planning a comeback !
Status: Offline
Reply With Quote
Mar 10, 2010, 03:47 PM
 
What if you use a line breaks (Shift + Enter) instead of a Paragraph ?

-t
     
ibook_steve
Moderator
Join Date: Oct 2001
Location: San Jose, CA
Status: Offline
Reply With Quote
Mar 10, 2010, 03:58 PM
 
I was talking about the final paragraph mark and accidentally copying over an extra empty paragraph at the bottom, but what you're saying is that a single paragraph mark is coming over as 2 carriage returns. Don't know what to tell you about that. I'd just blame Microsoft.

What happens when you paste into other apps: stickies, Textedit, etc.?

Steve
Celebrating 10 years and 4000 posts on MacNN!
     
besson3c
Clinically Insane
Join Date: Mar 2001
Location: yes
Status: Offline
Reply With Quote
Mar 10, 2010, 07:05 PM
 
Yeah, if Mail is trying to preserve any of the crap formatting embedded into your Word document, these sorts of problems can happen as anybody who has messed around with pasting into the TinyMCE editor from Word will tell you.

I'd try converting the document to plain text first prior to your copy/paste. It will probably look better this way anyway.
     
msuper69
Professional Poster
Join Date: Jan 2000
Location: Columbus, OH
Status: Offline
Reply With Quote
Mar 10, 2010, 09:40 PM
 
I'm using Word for Mac 2008 v 12.2.4 and SL 10.6.2.

Copy/Paste to Mail works fine here.
     
ghporter
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Mar 10, 2010, 09:43 PM
 
It appears that Word's "ΒΆ" (may be version dependent-I'm using Word 2004) comes through as CR/LF, and I think (at least in some situations), Mail reads a CR/LF as "carriage return" (new line) and "line feed" (new line). Like this:

CR/LF => /nl; /nl.

Glenn -----OTR/L, MOT, Tx
     
hab  (op)
Forum Regular
Join Date: Mar 2002
Location: San Francisco
Status: Offline
Reply With Quote
Mar 11, 2010, 01:58 AM
 
Thanks all.
Copy and paste into Stickies and TextEdit both come across fine with just one line feed for each paragraph mark.
I tried changing Mail Composing prefs between rich text format and plain text and still get 2 line feeds for each paragraph regardless of the setting.

Odd, especially when another person running the same software (Word v.12.2.4 [I updated last night] and Mac OSX v. 10.6.2).
21.5" iMac 2.7GHz i5; 15" FP iMac 0.8GHz G4, iPhone 5S
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 11:57 AM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,