Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Hardware - Troubleshooting and Discussion > iPhone, iPad & iPod > Messages still not syncing among iOS 12.1 on iPhone - macOS 10.14 - and iOS 12.0 iPad

Messages still not syncing among iOS 12.1 on iPhone - macOS 10.14 - and iOS 12.0 iPad
Thread Tools
And.reg
The Mighty
Join Date: Feb 2004
Location: Well the sports issue was within arm's reach but they closed up shop and kicked me out. And I'm out of toilet paper.
Status: Offline
Reply With Quote
Oct 11, 2018, 09:59 AM
 
GREETINGS.
On Tuesday, I started a texting conversation on my iPhone XS Max and received one reply. To keep this example minimal, I am just trying to sync these two messages among all of my devices.

On my Mac, I have the “Enable” checkbox selected.
On both my iPhone and iPad, I have the iMessage switch on.

So, it should just work if I send or receive a message in Messages on my iPhone, it should also show up on my Mac and iPad.
Instead, I have a blank window and no messages to select on my Mac’s Messages or on my iPad’s Messages.

What’s going on?
On behalf of my 14.8 years of literary forum genius at MacNN, this inspiritional post comes from the heart of yours truly,
And.reg, "The Mighty" Pain in the Ass
     
And.reg  (op)
The Mighty
Join Date: Feb 2004
Location: Well the sports issue was within arm's reach but they closed up shop and kicked me out. And I'm out of toilet paper.
Status: Offline
Reply With Quote
Oct 21, 2018, 04:06 PM
 
[...10 days later...]

Greetings again

I have not yet received a response as to why text messages between my iPhone and my Mac (and my iPad for that matter) do not synchronize. They appear on my iPhone, but on my Mac and iPad, Messages displays a blank window.

How do I get Messages that are on my iPhone to sync onto my Mac?
On behalf of my 14.8 years of literary forum genius at MacNN, this inspiritional post comes from the heart of yours truly,
And.reg, "The Mighty" Pain in the Ass
     
P
Moderator
Join Date: Apr 2000
Location: Gothenburg, Sweden
Status: Offline
Reply With Quote
Oct 25, 2018, 04:45 AM
 
When you say that you have the iMessage switch on, do you mean in the iCloud settings?
The new Mac Pro has up to 30 MB of cache inside the processor itself. That's more than the HD in my first Mac. Somehow I'm still running out of space.
     
And.reg  (op)
The Mighty
Join Date: Feb 2004
Location: Well the sports issue was within arm's reach but they closed up shop and kicked me out. And I'm out of toilet paper.
Status: Offline
Reply With Quote
Oct 25, 2018, 10:21 AM
 
No.

I had no idea that there was ANOTHER switch, and that it was in iCloud settings.



So I finally got to activate the authentication on both my iPhone and my Mac.

Now how do I get my past messages to sync? I just went into my Mac Messages > Preferences > iMessage > [CHECKED] "Enable Messages in Cloud" > "Sync Now"

Pressed the button a few times...

...and my iPhone's messages are STILL not synced to my Mac.

Now what?
On behalf of my 14.8 years of literary forum genius at MacNN, this inspiritional post comes from the heart of yours truly,
And.reg, "The Mighty" Pain in the Ass
     
andi*pandi
Moderator
Join Date: Jun 2000
Location: inside 128, north of 90
Status: Offline
Reply With Quote
Oct 25, 2018, 06:13 PM
 
it may be a going forward thing.
     
And.reg  (op)
The Mighty
Join Date: Feb 2004
Location: Well the sports issue was within arm's reach but they closed up shop and kicked me out. And I'm out of toilet paper.
Status: Offline
Reply With Quote
Oct 25, 2018, 07:41 PM
 
I just turned my iPhone Xs Max sideways to find the answer, in Messages there is a little blurb that says:

Upload to iCloud paused. Plug in your phone and connect to WiFi.
On behalf of my 14.8 years of literary forum genius at MacNN, this inspiritional post comes from the heart of yours truly,
And.reg, "The Mighty" Pain in the Ass
     
And.reg  (op)
The Mighty
Join Date: Feb 2004
Location: Well the sports issue was within arm's reach but they closed up shop and kicked me out. And I'm out of toilet paper.
Status: Offline
Reply With Quote
Nov 6, 2018, 09:55 AM
 
Help!

Messages are still not syncing between my iPhone and my iPad.

On both my iPhone and my iPad, I have Settings > Messages > iMessage switched on, and I have Settings > iCloud > Messages switched on.

Both devices are online.

How do I get my iPad to sync to the messages that are on my iPhone??
On behalf of my 14.8 years of literary forum genius at MacNN, this inspiritional post comes from the heart of yours truly,
And.reg, "The Mighty" Pain in the Ass
     
andi*pandi
Moderator
Join Date: Jun 2000
Location: inside 128, north of 90
Status: Offline
Reply With Quote
Nov 6, 2018, 11:42 AM
 
do both have wifi turned on? turn it off and on again.
     
And.reg  (op)
The Mighty
Join Date: Feb 2004
Location: Well the sports issue was within arm's reach but they closed up shop and kicked me out. And I'm out of toilet paper.
Status: Offline
Reply With Quote
Nov 6, 2018, 01:41 PM
 
Already did that. I said that both devices are connected.
On behalf of my 14.8 years of literary forum genius at MacNN, this inspiritional post comes from the heart of yours truly,
And.reg, "The Mighty" Pain in the Ass
     
And.reg  (op)
The Mighty
Join Date: Feb 2004
Location: Well the sports issue was within arm's reach but they closed up shop and kicked me out. And I'm out of toilet paper.
Status: Offline
Reply With Quote
Nov 6, 2018, 06:31 PM
 
Oh my gosh... Why has no one told me about "Text Message Forwarding"????

So I just found YET ANOTHER setting that I need to have switched on, just to sync my messages.

Alright let me state this here, both for my (future) reference (because I might forget) AND for ANYONE else who is just confused beyond all of creation as to why their messages are not syncing:

Step 1: On ALL iOS devices Turn on Settings > Messages > iMessage from which you wish to have syncing, with all checkboxes for all numbers and emails.
Step 2: On ALL Macs, turn on Messages > Preferences > iMessage > all checkboxes for all numbers and emails.
Step 3: Enable two-factor authentication on ALL iOS devices AND ALL Macs.
NOTE: You MUST have all devices together so that one can receive a code to be entered on the other device.
Step 4: Enable Messages in iCloud on ALL iOS devices AND ALL Macs.
Step 5: On your iPhone, enable Text Message Forwarding (which will allow sending and receiving, despite the misleading title of "forwarding" as if it's only one way...) and select ALL iOS devices AND ALL Macs.
NOTE: You MUST have all devices together again so that one can receive a code to be entered on the other device.


GEEBUZ JUMPING CHRISTMAS!! TOO DAMN CONFUSING, AND NOT EXPLICITLY STATED CLEARLY ANYWHERE!!!!!!!!

Friggin HELL, Apple!

THAT WHOLE PROCESS is what it takes, JUST to get messages to sync?

How does ANYBODY figure this out?

I have 27 years of experience using Macs and am so shocked that even I could not figure that out without fumbling around my phone's settings like a monkey until something worked.

This is 2018 for Pete sakes!

This is NOT the "it just works" mantra that I grew up with from Apple.

Why is there not a simple, single, "Sync Among Devices" setting that automatically configures all of this crap?!?!?
On behalf of my 14.8 years of literary forum genius at MacNN, this inspiritional post comes from the heart of yours truly,
And.reg, "The Mighty" Pain in the Ass
     
subego
Clinically Insane
Join Date: Jun 2001
Location: Chicago, Bang! Bang!
Status: Online
Reply With Quote
Nov 6, 2018, 09:30 PM
 
This sounds abnormal.

I never had to set anything to get it all to sync.

When I got my X, I wasn’t paying attention during setup, and it got unsynced. Getting it to resync wasn’t a hassle.
     
andi*pandi
Moderator
Join Date: Jun 2000
Location: inside 128, north of 90
Status: Offline
Reply With Quote
Nov 7, 2018, 12:54 PM
 
I don't have two-factor auth set up, but then not all my devices are updated or compatible to be updated. I've had issues where it got disconnected (switching phones was a little scary) but got right back up easily enough.

What really amazes people is answering phone calls on the ipad.

are you running betas?
     
And.reg  (op)
The Mighty
Join Date: Feb 2004
Location: Well the sports issue was within arm's reach but they closed up shop and kicked me out. And I'm out of toilet paper.
Status: Offline
Reply With Quote
Nov 7, 2018, 01:54 PM
 
Not anymore. And before I could switch the Messages switch in iCloud to on, I was required by software prompts to setup 2FA.
On behalf of my 14.8 years of literary forum genius at MacNN, this inspiritional post comes from the heart of yours truly,
And.reg, "The Mighty" Pain in the Ass
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 09:17 AM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,