Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Hardware - Troubleshooting and Discussion > Consumer Hardware & Components > won't recognize external hard drive after unsafe eject

won't recognize external hard drive after unsafe eject
Thread Tools
kjbee
Junior Member
Join Date: Feb 2007
Location: Maryland
Status: Offline
Reply With Quote
Jan 15, 2008, 08:38 AM
 
Bad habit from PCs - i NEVER remember to do a 'safe eject' before i unplug a jump drive or whatever from the mac. Well, i got a 500 gig external hard drive (mybook) for xmas and did this the first time i used it (rt after xmas), was afraid, then plugged it back in and it was ok. Then i did it yet again when I used it last night, and now when I plug it in, the lights are on on the external drive, but my computer does not seem to recognize it in any capacity. What can I do?!

sub-question: it came installed with memeo lifeAgent. Is this worth buying after the trial period, or should I just drag over my home folder when it's connected? If I drag over, will it replace the folder each time or make a new version of it?


 MacBook 2,1 - 13.3" - Snow Leopard (rawr)
2.0 GHz Intel Core 2 Duo/SuperDrive/4GB RAM (Crucial)/
500GB Hard Drive (Seagate Momentus)/
500GB External HD (MyBook)
     
rjt1000
Senior User
Join Date: Jul 2003
Location: Asia
Status: Offline
Reply With Quote
Jan 15, 2008, 09:35 AM
 
If it shows up in Disk utility, you can try disk first aide to repair the disk.
     
kjbee  (op)
Junior Member
Join Date: Feb 2007
Location: Maryland
Status: Offline
Reply With Quote
Jan 16, 2008, 01:27 AM
 
...and if it doesn't show up??


 MacBook 2,1 - 13.3" - Snow Leopard (rawr)
2.0 GHz Intel Core 2 Duo/SuperDrive/4GB RAM (Crucial)/
500GB Hard Drive (Seagate Momentus)/
500GB External HD (MyBook)
     
Macola
Mac Elite
Join Date: Mar 2001
Location: Madison, WI
Status: Offline
Reply With Quote
Jan 16, 2008, 05:15 PM
 
Try DiskWarrior. If it doesn't see the drive, your next best option is to remove it from the enclosure, put into another Mac, and try DiskWarrior again.
I do not like those green links and spam.
I do not like them, Sam I am.
     
kjbee  (op)
Junior Member
Join Date: Feb 2007
Location: Maryland
Status: Offline
Reply With Quote
Jan 17, 2008, 08:41 PM
 
well, i took them both to work to see if anyone there had any suggestions and voila—it just worked. Don't know why, I'd restarted etc 5 or 6 times at home, but who knows. Hopefully when I plug it back in here (with a large sticky on the HD that says "EJECT!!"), it'll still be a-OK.


 MacBook 2,1 - 13.3" - Snow Leopard (rawr)
2.0 GHz Intel Core 2 Duo/SuperDrive/4GB RAM (Crucial)/
500GB Hard Drive (Seagate Momentus)/
500GB External HD (MyBook)
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 05:54 PM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,