Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Hardware - Troubleshooting and Discussion > iPhone, iPad & iPod > Begone Damned Hostspot!

Begone Damned Hostspot!
Thread Tools
Thorzdad
Moderator
Join Date: Aug 2001
Location: Nobletucky
Status: Offline
Reply With Quote
Sep 28, 2023, 10:07 PM
 
Please riddle me this...
As you might know, Xfinity’s wifi gateways also broadcast an open hotspot for any nearby Xfinity customers. I see them all the time on my phone, on the list of available wifi networks. I never use them. My phone ignores them.

My wife’s iPhone though seems to love the Xfinity hotspots. It will often jump on one of those instead of the wifi network it’s supposed to get on (i.e. networks she’s previously logged into) even though she’s never ever connected to any Xfinity hotspot. Ever.

This has even happened at home, where her phone has jumped onto some neighbor’s nearby Xfinity hotspot instead of our home network (we’re on xfinity, but use our own modem and router.)

My iPhone (6s) has never done this. Ever. I’m baffled as to why her iPhone (second-gen SE) acts like this. Any ideas?
     
Brien
Professional Poster
Join Date: Jun 2002
Location: Southern California
Status: Offline
Reply With Quote
Sep 29, 2023, 02:05 AM
 
Do you have Xfinity as a mobile provider? If not I’m stumped too.
     
reader50
Administrator
Join Date: Jun 2000
Location: California
Status: Offline
Reply With Quote
Sep 29, 2023, 04:10 AM
 
Check your WiFi settings. In macOS, there's a checkbox [x] Ask to join Personal Hotspots. If checked, your device has to ask you before joining a new hotspot. Compare the WiFi settings between the two phones, see what options differ.
     
Spheric Harlot
Clinically Insane
Join Date: Nov 1999
Location: 888500128, C3, 2nd soft.
Status: Online
Reply With Quote
Sep 29, 2023, 06:01 AM
 
Connect to Xfinity network. Then, in Settings, click "info" and "Ignore this network".

I had this with a free public wifi hotspot service all around the city that I'd connected to once, for testing purposes, a decade ago.
     
mukulb
Fresh-Faced Recruit
Join Date: Sep 2019
Status: Offline
Reply With Quote
Mar 1, 2024, 06:35 AM
 
Hi everyone! I encountered a similar issue with my iPhone automatically connecting to Xfinity hotspots. What worked for me was going to Settings > Wi-Fi, tapping the 'i' icon next to the Xfinity network, and selecting 'Forget This Network.' This stopped my iPhone from automatically connecting to these hotspots. Hope this helps!
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 05:41 AM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,