Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Hardware - Troubleshooting and Discussion > iPhone, iPad & iPod > Found a major bug in iPhone 2.1 already

Found a major bug in iPhone 2.1 already (Page 2)
Thread Tools
I'mDaMac
Senior User
Join Date: Jan 2001
Location: Southern CA
Status: Offline
Reply With Quote
Sep 16, 2008, 11:13 PM
 
Major bug my foot. Two other people on Apple discussion boards have it and one curiously is also from Canada and just recently registered to post that they too had the problem. I cannot replicate this on either my iPhone 3G or my iPhone 2G. I have IMAP, POP, and MobileMe. My iPhone 2G is also Jailbroken and does NOT exhibit this problem.

There is probably something corrupt in your backup. You should probably think about restoring and setting up your iPhone as a new phone. I know, sucks to lose all that data, but it's better than having the damn thing crash every time you scroll to the bottom of the Mail, Contacts pane.
Who'sDaMac?
     
osiris
Addicted to MacNN
Join Date: Sep 2000
Location: Isle of Manhattan
Status: Offline
Reply With Quote
Sep 17, 2008, 09:06 AM
 
Maybe a bug or not, but since 2.1, my Usage indicator is way off.
Resetting, charging overnight, etc doesn't seem to reset to it zero like it did before. So according to Usage, I've gotten almost 3 days standby and 10 hours talk time on one charge.
"Faster, faster! 'Till the thrill of speed overcomes the fear of death." - HST
     
analogue SPRINKLES  (op)
Professional Poster
Join Date: Feb 2007
Location: T •
Status: Offline
Reply With Quote
Sep 17, 2008, 12:29 PM
 
Originally Posted by I'mDaMac View Post
Major bug my foot. Two other people on Apple discussion boards have it and one curiously is also from Canada and just recently registered to post that they too had the problem.
Oh I get it... so you are suggesting that it is me faking it right?

Do you perhaps think this bug might be CARRIER specific or that never crossed your sharp little mind?

     
Mrjinglesusa
Professional Poster
Join Date: Feb 2002
Location: Why do you care?
Status: Offline
Reply With Quote
Sep 17, 2008, 03:43 PM
 
Originally Posted by analogue SPRINKLES View Post
Within 3 minutes of installing 2.1 on my iPhone I already found a serious bug on my 3G iPhone which also happens on my friends 2.5G iPhone running 2.1

Going into setting/mail,contacts,calenders scroll to the bottom.... CRASH.

What in the world is going on with quality control over at Apple? Seriously if this is happening to the only 2 iPhones I have seen that has upgraded it must be widespread.

Can't wait for 2.1.1 in a few days.
Originally Posted by analogue SPRINKLES View Post
Oh I get it... so you are suggesting that it is me faking it right?

Do you perhaps think this bug might be CARRIER specific or that never crossed your sharp little mind?

Clearly, your sharp little mind didn't think it was carrier specific 5 days ago.
2.3GHz i7 15" Retina Macbook Pro (Late 2013)
     
jokell82
Professional Poster
Join Date: May 2001
Location: Hampton Roads, VA
Status: Offline
Reply With Quote
Sep 17, 2008, 08:43 PM
 
Never seen so much animosity over a fraking bug report.

All glory to the hypnotoad.
     
analogue SPRINKLES  (op)
Professional Poster
Join Date: Feb 2007
Location: T •
Status: Offline
Reply With Quote
Sep 18, 2008, 02:06 PM
 
Well all I have to say is BURN on you guys. I just got a call from Jason at apple who monitors the Apple forums and he told me that they are interested in this bug and want to trace down the problem to send to the engineers to fix.

After he sent me an email asking me to send the crash logs stored on my computer.

So once again...
     
Eug
Clinically Insane
Join Date: Dec 2000
Location: Caught in a web of deceit.
Status: Offline
Reply With Quote
Sep 18, 2008, 02:50 PM
 
I don't have this problem. iPhone 3G, Firmware 2.1.

I am on the same network as aS, albeit with a different company. (I'm on Fido, which is owned by Rogers. They both use the same network, but their iPhones are not interchangeable.)
     
MacnTX
Fresh-Faced Recruit
Join Date: Apr 2004
Status: Offline
Reply With Quote
Sep 19, 2008, 06:52 PM
 
Nope, I could not replicate this problem on two separate 2.5G iPhones here either.
     
analogue SPRINKLES  (op)
Professional Poster
Join Date: Feb 2007
Location: T •
Status: Offline
Reply With Quote
Sep 23, 2008, 03:20 PM
 
I found another person who has this problem. Those of us that are suffering from this bug also get a crash when going into date and time settings.
     
Railroader
Banned
Join Date: Jun 2005
Location: Indy.
Status: Offline
Reply With Quote
Sep 23, 2008, 04:22 PM
 
So, have you actually went to a Apple Store to have a genius look at it, or are you just going to keep bitchin' on here?
     
turtle777
Clinically Insane
Join Date: Jun 2001
Location: planning a comeback !
Status: Offline
Reply With Quote
Sep 24, 2008, 01:31 AM
 
Originally Posted by analogue SPRINKLES View Post
Just confirmed it is happening on a another 3G iPhone.

So far that means one 2.5G iphone and two 3G iPhones.
Only in Canada ?

-t
     
analogue SPRINKLES  (op)
Professional Poster
Join Date: Feb 2007
Location: T •
Status: Offline
Reply With Quote
Sep 24, 2008, 04:32 PM
 
Originally Posted by turtle777 View Post
Only in Canada ?

-t
And by the looks of it Australia
     
kmkkid
Professional Poster
Join Date: Mar 2002
Location: Brantford, ON. Canada
Status: Offline
Reply With Quote
Sep 24, 2008, 07:30 PM
 
Doesn't crash on mine.

I'm from Ontario, Canada; and on Rogers.

Hope you get it sorted out.
     
 
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 02:49 PM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,