Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > Developer Center > ParamText in Dialogs in Panther?

ParamText in Dialogs in Panther?
Thread Tools
jabaro
Fresh-Faced Recruit
Join Date: Jul 2001
Location: Wheeling, WV
Status: Offline
Reply With Quote
Oct 8, 2004, 10:14 AM
 
I have a program I wrote about 10 years ago that I recently carbonized for OS X. I used ProjectBuilder in 10.2 and it worked fine. I just learned that the dialogs no longer work in Panther. The static text fields show ^0^1, which should have been replaced with something else at runtime. I use ParamText to replace these placeholders with strings from resources. I've been debugging in Panther and everything seems to work - it finds the string resources and correctly passes the strings in ParamText to dialogs created from nibs. ParamText is, as far as I can tell, still supported. So what's up? Why does this program work in 10.2 but breaks in 10.3? Has something changed that I can't find documented?

John
     
Bwa
Dedicated MacNNer
Join Date: Oct 2000
Location: Somerville, MA and San Jose, CA
Status: Offline
Reply With Quote
Oct 15, 2004, 03:55 AM
 
Originally posted by jabaro:
I have a program I wrote about 10 years ago that I recently carbonized for OS X. I used ProjectBuilder in 10.2 and it worked fine. I just learned that the dialogs no longer work in Panther. The static text fields show ^0^1, which should have been replaced with something else at runtime. I use ParamText to replace these placeholders with strings from resources. I've been debugging in Panther and everything seems to work - it finds the string resources and correctly passes the strings in ParamText to dialogs created from nibs. ParamText is, as far as I can tell, still supported. So what's up? Why does this program work in 10.2 but breaks in 10.3? Has something changed that I can't find documented?

John
Just a data point: My ParamText() calls in 3 shipping apps all work fine on all versions of OS X.
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 09:07 PM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,