Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > Applications > Mac OS 9 server running Webstar 4.5 crashing daily

Mac OS 9 server running Webstar 4.5 crashing daily
Thread Tools
drgubin
Fresh-Faced Recruit
Join Date: Dec 2003
Location: new york city
Status: Offline
Reply With Quote
Dec 9, 2003, 01:28 PM
 
I have tried turning off various extensions, running Disk Warrior, among other things, but the server keeps crashing at least once a day. There is never more than 12 people at a time logged onto it. Can someone please help?
     
theolein
Addicted to MacNN
Join Date: Feb 2001
Location: zurich, switzerland
Status: Offline
Reply With Quote
Dec 9, 2003, 03:50 PM
 
Have you looked at the server logs to see what those people are sending to the server? Someone might have discovered a buffer overflow and be sending maliscious requests to your machine.

Apart from that, have you checked the usual things, such as RAM allocation, dick space available etc.
weird wabbit
     
drgubin  (op)
Fresh-Faced Recruit
Join Date: Dec 2003
Location: new york city
Status: Offline
Reply With Quote
Dec 9, 2003, 04:01 PM
 
Yes, I have tried that and found nothing. As far as the RAM is concerned, there is 512 Megs of RAM on this machine. 200 of which are allocated for the Webstar. But thanks.
     
theolein
Addicted to MacNN
Join Date: Feb 2001
Location: zurich, switzerland
Status: Offline
Reply With Quote
Dec 10, 2003, 07:13 AM
 
Have you allocated enough RAM? It might be simply something like a memory leak that is continually asking for more memory.

Have you tried pinpointing exactly when it crashes? Is it always the same time or same event etc?

Also, does it understand http 1.1, which might be some of the requests you're getting. IIRC, Webstar is quite old and might not support or understand the newer protocol.

Also, could you post the bit of the server log that is just before the crash. maybe you're missing something.

Finally, why don't you run OSX? You won't have those problems there.
weird wabbit
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 06:15 PM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,