Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Networking > Help with vpn hosting. Clients on various versions of OS X

Help with vpn hosting. Clients on various versions of OS X
Thread Tools
inglesworth
Fresh-Faced Recruit
Join Date: Aug 2018
Status: Offline
Reply With Quote
Aug 15, 2018, 03:20 PM
 
We used to host a VPN server for our outside contractors on an old mac mini running the server app. That computer has been work down and now constantly freezes, and is very slow to boot up, etc. This caused a lot of down time on our VPN. We recently installed a new Dell Sonicwall firewall, and decided to host the VPN through it so as to alleviate relying on a computer to be up all the time.

Some of our outside contractors are less computer savvy than one would hope. So having minimal change to their workflow was pretty important. We had it set up as an L2TP vpn server, and our contractors were able to use the built in Mac OS ability to connect to the vpn through the System Preferences>Preferences. We created a configuration profile in the OS X Server app, and it was easy enough for everyone to double click and install on their systems.

When on the phone with the tech company who would end up installing the new firewall, I asked if our contractors would continue to be able to connect this way, and was told yes. The tech who showed up, was absolutely not familiar with mac at all, unfortunately. He told me that there was no way for anyone to connect to the VPN without a client software from sonicwall. My issue, is that our contractors have various versions of OS (pretty much all versions between 10.7 and 10.12). I doubt that Dell's sonicwall client software will be compatible as far back as we need it to be.

Well, I discovered that the sonicwall is actually capable of doing L2TP, and I set it up that way to try and alleviate any big mishaps with people who are less computer inclined installing software, and probably messing it up, etc. I set up this VPN, and made the sharedsecret the same as before, the address the same as before and so on. I and a few others are able to connect from off-site. However, some others are unable to connect. It appears (so far) that all the people able to connect are running 10.11 or 10.12. This leads me to believe that there must be some kind of setting that I am missing that would allow the older OS systems to connect.

If anyone has any insight in this at all, your help is greatly appreciated.
     
reader50
Administrator
Join Date: Jun 2000
Location: California
Status: Offline
Reply With Quote
Aug 15, 2018, 04:41 PM
 
You aren't giving us many specifics to work with. Like what server app you were using on the Mini. Or what version of SonicWALL you're running now. Their client system requirements are in the admin guide for each version. I found one guide (for sonicwall 10.6.2) which supports Mac back to 10.6, and in some cases to 10.5.

So besides posting more info, perhaps you could try their client software on the earlier systems. You won't know if their client works without a try. You could also test this yourself first, if you have a free computer with earlier OSs on different partitions. For development testing.
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 03:22 AM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,