Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Networking > "...error joining the AirPort network 'xxxxx'."

"...error joining the AirPort network 'xxxxx'."
Thread Tools
whgiii
Fresh-Faced Recruit
Join Date: Oct 2005
Status: Offline
Reply With Quote
Jan 13, 2006, 03:40 PM
 
All of a sudden, I am getting the error message, "There was an error joining the AirPort network 'xxxxx'," on my G4 PowerBook (OS 10.4.4) whenever trying to connect to ANY wireless network, either my Airport Express or places where I have previously had no connection problems. The network is recognized in the Airport menu, but does not show up in Airport Setup Assistant or Airport Admin Utility so I cannot configure or even install firmware upgrades. The problem started while trying the new "multiple speakers" feature on Itunes 6.0.2. It worked for a few minutes, then sound stopped at the Airport Express connected speaker. Since then I cannot access any wireless networks.
     
fesdds
Junior Member
Join Date: Feb 2006
Location: Dallas, TX
Status: Offline
Reply With Quote
Feb 23, 2006, 09:19 PM
 
I had a Netgear 802.11b router that was working great, but I got a D-Link 802.11g to try and get quicker networking. It worked ok the first day but since then I gett the same message. I not sure what to do. I have restarted the network several times to no avail. I'll keep and ear out for some answers.
     
tooki
Admin Emeritus
Join Date: Oct 1999
Location: Zurich, Switzerland
Status: Offline
Reply With Quote
Feb 24, 2006, 10:48 AM
 
I've gotten this now and then, with any of the routers I've used over the years.

1. Restarting sometimes fixes it.

2. Sometimes, turning AirPort off and back on is enough.

3. If not, try choosing "Other..." from the AirPort menu and enter the network name and password manually.

4. If not, go into your keychain (/Applications/Utilities/Keychain Access). For each of the keychains (the top-left box), select it and then choose Keychain Access -> Keychain First Aid and do a repair.

5. If that doesn't fix it, look in both your "login" keychain and the "system" keychain and delete all the keys whose kind is "AirPort Network Password". Then restart and try to connect.

tooki
     
yticolev
Forum Regular
Join Date: May 2002
Location: MA
Status: Offline
Reply With Quote
Jun 10, 2006, 12:20 PM
 
Hi Tooki,

I'm having the dreaded "error joining" dialog box on connection attempts to open otherwise working networks including the local library which previously worked. Although I do not use any networks with passwords on my Aluminum G4, I tried all of your suggested solutions ("None" under wireless security when entering network name in "Other"). I've also tried every other solution in this forum including deleting all network and airport plists where ever found.

Other attempts to find a solution included running fsck -fy (clear), and all of ONYX's routines including cache clearing (an impressive 400MB).

Some networks continue to work, but two that work on other laptops return this error. No recent changes in software, only previous similar error messages are under certain circumstances: low signal, noise (as reported in iStumbler), or the router active but not actually connected to the Internet. My laptop will ask me if I want to join the network when I'm in range but does not connect. Manual attempts return the dialog even though the network appears in the Airport menu and iStumbler with excellent signal strength.

Any thoughts? I'm at a loss and considering reinstalling the system. Please save me from that! Everything is up to date except for the last security update.
     
yticolev
Forum Regular
Join Date: May 2002
Location: MA
Status: Offline
Reply With Quote
Jun 23, 2006, 05:49 PM
 
OK, I've done a lot of research and mostly what I've discovered is that there are a fair number of people with this issue and no definitive fix. I went to the library yesterday, and lo and behold, my Albook now connects to the network. However, there was an old gentleman there with his 17" who could not connect. Just like me, the library network showed up on his Airport menu but error connecting. And his, just like mine, was working the day before.

So there we were, one working and one not and no idea why for either one. Anyone have any ideas?
     
jdu
Fresh-Faced Recruit
Join Date: Oct 2006
Status: Offline
Reply With Quote
Oct 6, 2006, 01:55 PM
 
Hi! Just got my macbook a bit over two months ago, along with an airport extreme base. a couple of days back, my internet connection just conked out. first, i would be able to enter my network then 5 minutes later, i'd lose it. then when i try to reconnect, i just receive the error message "there was an error joining the Airport network...". I restart my computer and I'm connected but 5 minutes later, it's gone again! I didn't change any settings at all and my friend, who is also on the same network with an ibook, has no problems at all. i called apple for help and spent 2 hours with them but they couldn't help! they said once i update to 10.4.8, i should be able to fix the problem. so i patiently started and restarted my computer, just so i can update it before the 5minute internet connection ran out. i finally did, but lo and behold, I CANNOT CONNECT at all!!! i tried using the network from uni and i got that 5 minute connection again but lost it. is there perhaps a glitch in my airport card? just switched to mac and i invested so much in it. can anyone help? i tried all the troubleshooting tips but nothing worked. i'm just so frustrated because i need my macbook for uni and the service centre said they wouldn't be able to check my mac until late next week. thanks!
     
Ryanhdd
Fresh-Faced Recruit
Join Date: Sep 2006
Status: Offline
Reply With Quote
Oct 6, 2006, 11:16 PM
 
Im having the same problem. It does not change no matter what i do. Im really getting sick of it. I can see it and everything but it just will not connect. Im sooooo pissed. Dont know what to do.
     
ghporter
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Oct 7, 2006, 10:23 AM
 
Do ALL the steps tooki listed in February-ALL OF THEM. If that doesn't fix it, try deleting the AirPort keychain and then rejoin the network by re-entering the passphrase.

This is a common set of symptoms, but not a "common problem" because there are a number of mechanisms involved that can cause an "error joining..." problem, including the AirPort base being goofy, YOUR COMPUTER being goofy, and simple chance. If you follow these steps every time, you will at least narrow down what is actually happening and with that information, you can start looking for a real cause.

Glenn -----OTR/L, MOT, Tx
     
jdu
Fresh-Faced Recruit
Join Date: Oct 2006
Status: Offline
Reply With Quote
Oct 8, 2006, 12:05 PM
 
Thanks! I tried all of that, one at a time, and still nothing. I was comparing my settings to my friends ibook, which can connect properly, and this is the only difference:

Network > Airport > TCP/IP tab > Configure IPV4 is set to Using DHCP and the fields for IP Address, Subnet mask and router are filled. She also has an IPV6 address. When I select "Using DHCP" in mine, nothing happens. I tried selecting "manually" instead and copying her settings but still won't work. I'm not that techie but is this perhaps where the problem lies?

Weird thing is, I can connect whenever I restart my computer. Then no matter what I do (if I open another program or not), I just lose my connection 3 to 10 minutes after. Then my mac can't detect the network at all. Will it help if I reformat my mac? Since I'm not that good with macs, I don't want to try anything that will make the situation worse. I just feel so bad since i love my mac, it's new BUT I've had more problems with it than i ever did with my pc.
     
buffalolee
Mac Enthusiast
Join Date: Oct 2001
Location: Syracuse, NY
Status: Offline
Reply With Quote
Oct 9, 2006, 12:18 PM
 
I am in process of downgrading the firmware from v5.7 to v.5.51 because of these problems you stated.
     
jdu
Fresh-Faced Recruit
Join Date: Oct 2006
Status: Offline
Reply With Quote
Oct 10, 2006, 07:20 AM
 
Thank you! What does a firmware do? Sorry. I'm quite new here. Also have a new problem. When I started my macbook earlier, I was not able to connect at all, not even for a second. In fact, my airport icon in the taskbar is missing. When I checked for my airport card in the system profiler, it said "No hardware found" :O I tried restarting and same thing. For some reason, my mac
cannot detect my airport card...
     
jdu
Fresh-Faced Recruit
Join Date: Oct 2006
Status: Offline
Reply With Quote
Dec 7, 2006, 10:56 PM
 
Hi buffalolee, everyone! Was able to solve the problem - brought my mac to next byte service center and they finally realized my airport card was malfunctioning and replaced it. Thanks for your help!
     
wubrew
Dedicated MacNNer
Join Date: May 1999
Location: Port Angeles, WA.
Status: Offline
Reply With Quote
Dec 8, 2006, 12:08 AM
 
I just activate the " Use Interference Robustness' from the drop down menu ofthe signal strength and solve that problem everytime.
It's "Brewed" not "Juiced"
     
ghporter
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Dec 8, 2006, 08:52 AM
 
Interference robustness is only effective when the problem is (or is related to) interference. It doesn't sound like this is the case in the OP's problem. Wubrew, when you have this kind of problem, does it present in exactly the same way-particularly do you get a good signal level with the correct network name?

Glenn -----OTR/L, MOT, Tx
     
sohailamir
Fresh-Faced Recruit
Join Date: Dec 2006
Status: Offline
Reply With Quote
Dec 8, 2006, 11:52 AM
 
If the AirPort still doesn't work, the other things you could do is turn off the fire wall or accept the desired ports just like I said in Reiders thread. Also make sure you have a static IP instead of a dynamic IP - If you don't know what this is then you could research it on google.
     
cwurld
Fresh-Faced Recruit
Join Date: Jan 2007
Status: Offline
Reply With Quote
Jan 10, 2007, 04:43 PM
 
I feel your pain....my wife just got a shiney new Macbook Pro and was having the symptoms you all describe. She even reinstalled the OS a few times. Things would work for a while then all of a sudden, for no obvious reason. she got the dreaded "...error joining..." message. I tried all the tricks above and none had any effect.

Lucky for me, we still had an old Airport Extreme Wireless Router. I plugged it into wireless router that came with my DSL service and viola...success (for now).

It seems kind of silly to have two wireless networks in our house. If this works, I might try to see if I can turn off the wireless part on the router that came w the DSL package. I have never had any trouble connecting my wintel machines to the Airport base.
     
acorder
Forum Regular
Join Date: Feb 2005
Location: Spokane, WA
Status: Offline
Reply With Quote
Jan 12, 2007, 08:05 PM
 
Good evening all. I've been having these same intermittent symptoms for the last two months or so, with three or four bars of signal strength when working, and error trying to connect when not. I happened to talk to a neighbor of mine who is a teach for the local school district, and he said that he currently had a Rev. A Intel iMac being repaired because of bad Airport antenna cabling. It was having the same issues as my 20" CD iMac. Anyone know if the Genius Bar folks will be able/willing to check this cabling on my computer if I take it in to them?
     
Blasphemy
Dedicated MacNNer
Join Date: Nov 2006
Location: Circa 1225, from the Old French
Status: Offline
Reply With Quote
Jan 13, 2007, 03:14 PM
 
I have intermittent problems with my WRT54G, MBP C2D & macbook CD. The connection drops and it can be minutes to hours before I can reconnect to the linksys router over wifi. A wired connection works flawlessly at any time.
     
iceclone
Fresh-Faced Recruit
Join Date: Jan 2007
Status: Offline
Reply With Quote
Jan 17, 2007, 02:22 AM
 
I'm a new mac user and it disappoints me that I'm having a lot of problems already in just a few months of having it (imac 20"). I'm sure that my airport express is working fine because two of the laptops in my house connects perfectly OK. There's got to be something wrong inside the iMac. I will call customer care tomorrow for help. They need to fix this before I change my mind on going back to using a PC.
     
ghporter
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Jan 17, 2007, 08:24 AM
 
Originally Posted by iceclone View Post
I'm a new mac user and it disappoints me that I'm having a lot of problems already in just a few months of having it (imac 20"). I'm sure that my airport express is working fine because two of the laptops in my house connects perfectly OK. There's got to be something wrong inside the iMac. I will call customer care tomorrow for help. They need to fix this before I change my mind on going back to using a PC.
If you posted some details about your particular setup and the issues you're encountering, we might be able to help you...

Glenn -----OTR/L, MOT, Tx
     
leakbox
Fresh-Faced Recruit
Join Date: Jan 2007
Status: Offline
Reply With Quote
Jan 22, 2007, 10:50 PM
 
All,

Brand new here....

After too long having issues, problems, viruses, and adware related to my son's PC, we "upgraded" to an iMac at Christmas.

His setup went flawless, and all was fine since Christmas. We moved his PC to my daughter's room. There were no problems whatsoever until last night, when suddenly he was disconnected. He was getting the dreaded "There was an error joining the AirPort Network XXXXX". We gave up after trying over and over last night. I had called Time Warner, and verified that the modem and wireless router were working fine. Both our PC and the one in my daughter's room worked fine.

This evening, after restarting, he was able to connect several times, only to find that it would lose its connection after a few minutes. Eventually, there was no way to connect at all. I shut down and re-started the modem (Arris model) as well as the router (Linksys 2.4 GHz -G model, 54Mbps, model WRT54G), to no avail.

As before, both other PCs are connecting fine. I don't buy that there's an obstruction or distance issue, as the distance from the router to his iMac is about 50 ft max, and it is seeing the router from next door!

I have been frantically searching the web, and there's more fixes and workarounds than the pope has hats. Telephone support is down until tomorrow...regardless, I need to try and find a fix, as he has finals this week, and needs to have a connection to keep his school work going.

From what I'm reading, he has done nothing wrong. I spent big money to "upgrade" to Apple, and now I'm finding heartache after only a few weeks of ownership. Can anyone provide advice to someone not overly savvy?

Thanks,

Greg
     
Amir2007
Fresh-Faced Recruit
Join Date: Apr 2007
Status: Offline
Reply With Quote
Apr 6, 2007, 08:42 PM
 
Here is how I fixed it. Mac's use broadcom wireless cards which have problems with many routers and WAP. Now this matters if these chips are used in systems not running Windows and the way I know this is from my experience with my Acer Ferrari (using BCM4318 chip) and Gentoo linux. This problem is a big issue when using WAP. If you use WEP you can connect. This is why libraries have WEP protocols and not WAP.

I bought my first Mac 2 days ago and after working with my existing wifi at home (WPA) for one day, it started acting up. I've switched to WEP and never had problem since.
     
ghporter
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Apr 6, 2007, 09:44 PM
 
Originally Posted by Amir2007 View Post
Here is how I fixed it. Mac's use broadcom wireless cards which have problems with many routers and WAP. Now this matters if these chips are used in systems not running Windows and the way I know this is from my experience with my Acer Ferrari (using BCM4318 chip) and Gentoo linux. This problem is a big issue when using WAP. If you use WEP you can connect. This is why libraries have WEP protocols and not WAP.

I bought my first Mac 2 days ago and after working with my existing wifi at home (WPA) for one day, it started acting up. I've switched to WEP and never had problem since.
I have to assume you mean WPA as in "WiFi Protected Access" instead of "WAP", which generally stands for "Wireless Access Point."

Glenn -----OTR/L, MOT, Tx
     
bobbem
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 13, 2007, 12:15 AM
 
Originally Posted by Amir2007 View Post
Here is how I fixed it. Mac's use broadcom wireless cards which have problems with many routers and WAP. Now this matters if these chips are used in systems not running Windows and the way I know this is from my experience with my Acer Ferrari (using BCM4318 chip) and Gentoo linux. This problem is a big issue when using WAP. If you use WEP you can connect. This is why libraries have WEP protocols and not WAP.

I bought my first Mac 2 days ago and after working with my existing wifi at home (WPA) for one day, it started acting up. I've switched to WEP and never had problem since.
That's useful to know, but I've always used WEP security and have had this problem for a few months now. I don't think that the problem is related to security protocols, because many of the people who have posted in this thread (myself included) have tried to remove all security from the network, and the problem persists.
     
wubrew
Dedicated MacNNer
Join Date: May 1999
Location: Port Angeles, WA.
Status: Offline
Reply With Quote
Jul 13, 2007, 10:31 AM
 
I used to have this problem periodically ( atleast once a month ) with Linksys router. Even after reset it will not work immediately. However if left unplugged for half a day it will work(!) then the cycle repeat itself. After I switch to Netgear I only have to reset it once last 2 years. The cable guy kept telling me that most call that he received from cable customers use linksys router. I have comcast.

Interference robustness is only effective when the problem is (or is related to) interference. It doesn't sound like this is the case in the OP's problem. Wubrew, when you have this kind of problem, does it present in exactly the same way-particularly do you get a good signal level with the correct network name?
On the road where areas with wifi activity and " Error joining net work XXX" IME usually mean weak signal.
It's "Brewed" not "Juiced"
     
Katarsa
Fresh-Faced Recruit
Join Date: Jul 2008
Status: Offline
Reply With Quote
Jul 18, 2008, 01:21 PM
 
I have a WEP network and I had to put a $ before entering the password. I used all of the other fixes here and was just about pulling my hair out, but the fix for me happened to have been that simple. I entered the network through Applications> Airport Setup Assistance> Setup airport to existing network and then I just put in the info again. Try that to re-input network name and pass.
     
mtnmama
Fresh-Faced Recruit
Join Date: Sep 2008
Status: Offline
Reply With Quote
Sep 12, 2008, 07:43 PM
 
I have a WEP network and I had to put a $ before entering the password.
What the heck?! The $ trick worked for me, too!
I have a PowerPC G4 laptop. I have a MacPro and a PC that also use the network with no problems. I received the error message on my laptop only after making my network WEP password protected. I tried all the fixes I saw listed and was finally thinking I should just upgrade to leopard on the laptop (as is my MacPro) and possibly get a new wireless card.

I went to the pull down under the signal strength, selected my network and got the password dialog box as I had about 50 times. This time, I entered the $ before my password and the network just opened up!

Anyone know why this works?! (i'm not complaining!)
     
ghporter
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Sep 12, 2008, 09:01 PM
 
Ummmm.... Guys, WEP is poo. On a stick. It is extremely seriously flawed, and thus almost trivial to break with easily and commonly available tools. It sucks. Switching to WPA solves this because WPA is actually secure. So I STRONGLY advise any and all readers to switch to Wireless Protected Access (or better, WPA2), and use a long, complex, and completely random key. Otherwise you're just locking up your valuables with a paper clip instead of a vault door.

Anyway, the '$' tells your AirPort device to interpret your input as hex characters (which are all you can use for a pure WEP key) rather than as plain text (which AirPort devices transparently translate into their hex equivalent).

Glenn -----OTR/L, MOT, Tx
     
Dominique
Fresh-Faced Recruit
Join Date: Sep 2008
Status: Offline
Reply With Quote
Sep 16, 2008, 09:07 AM
 
Im so stuck and fustrated.. in the house hold we have 2 pc's and i have a iBook G4. When my sister went to uni she took her pc.. so i set our Netgear DG834G ADSL router up on my Mums pc.. now though i keep getting the dreaded "There was an error joining the AirPort network...".

The connection is showing up in my AirPort drop down bar along side all the other wireless connections in the area.. which if i had the WEP i could connect to...so why can't i connect to mine!!! ARRGGHH!!! iv tried all of the suggested above, restart, Deleted my key chain etc etc but still nothing!! Im on breaking point now!!! PLEASE HELP!!!!
     
chungjy
Fresh-Faced Recruit
Join Date: Dec 2008
Status: Offline
Reply With Quote
Dec 2, 2008, 02:02 AM
 
Try putting a $ in front of your password.

1. Click the AirPort icon and select Open Internet Connect.
2. When the Internet Connect screen appears, click AirPort.
3. Look for Network and select your wireless network’s name or SSID.
4. Enter your wireless network key on the field provided then click OK.

Note: If your security encryption is WEP, kindly include a dollar sign ($) first and then your wireless network key.
     
ghporter
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Dec 2, 2008, 08:49 AM
 
Originally Posted by chungjy View Post
Try putting a $ in front of your password.

1. Click the AirPort icon and select Open Internet Connect.
2. When the Internet Connect screen appears, click AirPort.
3. Look for Network and select your wireless network’s name or SSID.
4. Enter your wireless network key on the field provided then click OK.

Note: If your security encryption is WEP, kindly include a dollar sign ($) first and then your wireless network key.
Dominique says that she doesn't have the password in the first place, so while it's true that adding a '$' in front of a hex password makes AirPort devices treat the password correctly, I don't think it'll help her.

Glenn -----OTR/L, MOT, Tx
     
static33
Fresh-Faced Recruit
Join Date: Feb 2009
Status: Offline
Reply With Quote
Feb 27, 2009, 10:44 AM
 
I have stumbled into the same problem as list in this post.
The solution I have been able to test and prove, involves changing settings in the router. The router must be set to Wireless B mode and you must try different channels to see which one works best. On a linksys WRT110 I used channel 6 - 2.437Ghz. I can't say it will work for all, but It did the trick for me.

The only reason I can see for this problem is the way the Airport card establishes communication with the router. Regardless, I have had success with this method multiple times.

Unfortunately, anyone using a open Wi-Fi and has no access to the admin configuration of the router, will have to wait for a possible firmware update.
     
Doc HM
Mac Elite
Join Date: Oct 2008
Location: UKland
Status: Offline
Reply With Quote
Feb 27, 2009, 04:28 PM
 
to nuke and pave go to library/preferences and delete the folder SystemConfiguration.

You can then rebuild your airport settings from scratch.

This fix may also help with the dreaded "another application has changed your network settings" bug in 10.4.11

Also remember that some older macs (any using the original Airport card) can only connect using WEP while some (newer netgears included) routers only offer WPA security.

Joining a network that already has "b" devices connected can also be problematical for g and n devices. If you have any b devices on the network disconnect them, connect up the g or n devices and then reconnect the b device.
This space for Hire! Reasonable rates. Reach an audience of literally dozens!
     
WaterPNP
Fresh-Faced Recruit
Join Date: Mar 2009
Status: Offline
Reply With Quote
Mar 5, 2009, 08:47 PM
 
Thank you so much to who ever suggested putting the $ before the WEP password, I wasted the whole day trying a bunch of things that seemed logical, but this worked in 2 seconds. Try it if you're having problems
     
ghporter
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Mar 6, 2009, 09:45 PM
 
Originally Posted by WaterPNP View Post
Thank you so much to who ever suggested putting the $ before the WEP password, I wasted the whole day trying a bunch of things that seemed logical, but this worked in 2 seconds. Try it if you're having problems
Welcome to our forums!

And it's indeed NOT obvious or logical to prepend a '$' to your hexadecimal key to get AirPort devices to process it correctly. Try this ONLY if you're using WEP (Wired Equivalent Privacy-which it ain't). The way the password is handled in WEP is "implementer-determined," meaning that any implementer can do whatever he pleases with passwords to turn them into actual keys. Apple's solution is quite smart and easy to use, it's just not at all like the rest of the WiFi industry's approach.

Oh, and if you're using WEP, STOP and upgrade to something that handles WPA or even WPA2. These are actually secure, whereas WEP is nearly trivial to break within minutes.

Again, welcome, and I'm glad you got things working.
( Last edited by ghporter; Jun 7, 2009 at 01:13 PM. Reason: Fixed VERY old typo)

Glenn -----OTR/L, MOT, Tx
     
Eug
Clinically Insane
Join Date: Dec 2000
Location: Caught in a web of deceit.
Status: Offline
Reply With Quote
Mar 10, 2009, 04:22 PM
 
You can also encounter this issue if you have your router set to WPA2. Old Apple 802.11b Airport cards do not support WPA2. You either have to use WEP or WPA (the latter preferred).
     
Khourshed
Fresh-Faced Recruit
Join Date: Oct 1999
Location: Jeddah
Status: Offline
Reply With Quote
May 9, 2009, 05:18 AM
 
on may 9th my google search dropped me here and it is my lucky day since $ trick did work for me
thank you
Khourshed
     
nickg
Fresh-Faced Recruit
Join Date: Jun 2009
Status: Offline
Reply With Quote
Jun 7, 2009, 02:05 AM
 
If the $ solution does not work for you, it doesn't for me. I don't know why. You can do the following, until you solve the prob or upgrade your router (I will be upgrading my wireless router to one that allows WPA.).

Change your SSID name.
Disable your SSID Broadcast.

That's it. Now the only way to access your wireless network since it's not being broadcast to all of your neighbors is to manually enter your network name or SSID (select other, enter the new SSID and select no password). That's it.

If you want more security:
In your Advanced Wireless area, Somewhere under Wireless Network Access select Restrict Access and enter the mac addresses of all of the computers that need wireless access through your router. Click Save and your set. To get a mac address just google how to get a mac address. (Both PC's and Mac's have mac addresses.)

When I try entering $ before my WEP password (when trying access the network wirelessly) only the following keys work, a,b,c,d,e,f. I don't get it. If i remove the $ then all of the keys on my macbook keyboard work. I tried to trick the system by creating a password using a,b,c,d,e,f but it didn't work. oh well.

This works pretty good for now.

Nick G.
TheoloTech.com
     
Simon
Posting Junkie
Join Date: Nov 2000
Location: in front of my Mac
Status: Offline
Reply With Quote
Jun 7, 2009, 02:47 AM
 
The reason it only accepts a,b,c,d,e,f is because the $ is telling it to expect hex.
     
ghporter
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Jun 7, 2009, 01:17 PM
 
Apple handles WEP passwords very differently from the way ALL other WiFi vendors do. Everyone else expects a WEP password to be hexidecimal. Apple, by default, accepts ASCII (plain text) and then simply applies the hex values of the text characters as the password. As Simon says, prepending the '$' forces the AirPort device to process the input as straight hex.

However, once again, "WEP is poo." It is trivially broken by even casual intruders using apps that are easy to find and free to download. It does not even discourage attempts to intrude on it, and there are numerous applications that can, in very little time, both intercept and read your traffic AND allow the intruder INTO your wireless network. This is a VERY Bad Thing. Switch to WPA, and do it now. Go to WPA2 if at all possible, because there is at least one exploit that allows an intruder to mess with you, though not to intercept your traffic or join your network-WPA2 does not have this vulnerability.

Further, as nickg recommends, change your SSID. It's pretty easy to mess with someone who leaves all sorts of default values in place, and leaving a default SSID almost announces "my admin password is also default." But turning off SSID broadcast is not really a security technique, and it often makes it hard for YOU to join your network. One better approach is to simply use a VERY obviously non-default SSID, like "Bob's Network" or "Shady Warez Here," or even "Keep Out You Leeches!" These at least imply that you've done something more than just unpacked and plugged in the router. Of course using real security techniques, including WPA2 with a very long and very random password is essential as well.
/soapbox

Glenn -----OTR/L, MOT, Tx
     
Simon
Posting Junkie
Join Date: Nov 2000
Location: in front of my Mac
Status: Offline
Reply With Quote
Jun 7, 2009, 04:18 PM
 
Originally Posted by ghporter View Post
However, once again, "WEP is poo."
Can't be repeated enough. Everybody should be using WPA2 or at the very least WPA.
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 04:51 PM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,