Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Hardware Hacking > Fixed an unexpected logic board problem

Fixed an unexpected logic board problem
Thread Tools
Patrick
Mac Elite
Join Date: Feb 1999
Location: California
Status: Offline
Reply With Quote
May 3, 2015, 08:55 PM
 
Haven't posted here in a while. Just over two years ago, I successfully swapped the logic board in my old iMac G5. The newer logic board starting giving me kernel panics on startup last month, with bizarre messages involving invalid memory access errors and a few others beyond my understanding. I opened it up and found it had blown a capacitor or three, as the G5 iMacs had been known to do. Oh well… at least I got two good years out of it… but hey, I figured I could do this again on the cheap, so I checked eBay last week and bought a new motherboard (same model) for all of 5 bucks more than I paid for the previous one.

I plugged everything in, hit the power button, and the iMac took 5 minutes to boot to the login window. Not a good sign. Then I found that the computer wouldn't detect the ethernet cable I had plugged in, nor would it recognize the Firewire bus (though my drive was receiving power). It also wasn't sleeping or restarting correctly. Damn.

This was better than nothing, though - and I can't really assume that the eBay vendor should've tested the board enough to know exactly what wasn't working. The USB did work, at least - I figured I could just go out and buy adapters for the ethernet and Firewire connections. Before that, this afternoon I decided to take out the logic board and inspect it for any visual damage - anything that might be causing short circuits, or whatnot.

And holy crap, I fixed it all.

Upon looking closely at the reverse side of the board (the one without all the connectors and caps), I noticed a bunch of hard water stains, as if the board had been splashed by something. I went to the medicine cabinet and got some isopropyl alcohol and cotton swabs, and started carefully cleaning. Then when I got to a few spots, the cotton swab started turning purple. WTF? Purple? Apparently there were some ink stains in various locations on the board, all in areas with a whole bunch of little transistor thingies which looked important, including under the strip with all the ports (one stain next to the FW ports and one under the ethernet port), near the graphics inverter connection, capacitors, and even the power supply. After getting all the ink stains off, I used some compressed air to blast away any cotton swab fibers, and started carefully putting the computer back together. Now everything's working fine - the ink had indeed been shorting out a few components, or whatever the explanation might be - I'm no electrician here. Still, I feel like a mad scientist. IT'S ALIVE!

Lesson learned: look closely before installing any circuit board purchased off eBay.
( Last edited by Patrick; May 3, 2015 at 09:08 PM. )
     
Mike Wuerthele
Managing Editor
Join Date: Jul 2012
Status: Offline
Reply With Quote
May 3, 2015, 10:59 PM
 
The iMac G5 motherboard was notorious for leaky capacitors too.
     
And.reg
The Mighty
Join Date: Feb 2004
Location: Well the sports issue was within arm's reach but they closed up shop and kicked me out. And I'm out of toilet paper.
Status: Offline
Reply With Quote
May 8, 2015, 10:35 AM
 
Yup. Had that happen 10 years ago.

Old capacitors ("X" cap):




New capacitors ("K" cap):

This one time, at Boot Camp, I stuck a flute up my PC.
     
Waragainstsleep
Posting Junkie
Join Date: Mar 2004
Location: UK
Status: Offline
Reply With Quote
May 23, 2016, 10:39 AM
 
I did the caps on a bunch of these boards. I still have a big roll of the damn things somewhere.
I have plenty of more important things to do, if only I could bring myself to do them....
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 10:02 PM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,