Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > Applications > Google hates Mail.app

Google hates Mail.app
Thread Tools
Thorzdad
Moderator
Join Date: Aug 2001
Location: Nobletucky
Status: Offline
Reply With Quote
Apr 29, 2020, 01:01 PM
 
I guess this goes here.

Firstly, my iMac, for a variety of logistical reasons, is frozen at 10.9.5. This includes, of course, whatever versions of Apple apps that shipped with 10.9, including Mail.app. FWIW, upgrading the iMac isn't an option for me.

I use Mail to access a handful of different email accounts, including four different Gmail accounts. Over the past couple of days, I've been bombarded by Google security alert emails to each Gmail account and their recovery email addresses, alerting me that they've detected access from an unknown device. The "unknown device" of course, is my Mac. The same Mac that has been accessing the accounts for years.

Looking further into things, it appears that Google considers my version of Mail as "untrusted." It seems that, no matter how many times I click "Yes, this was me," Google isn't getting the message.

Has anyone ever had to deal with something like this?

Oddly, this all started immediately after changing the password for my Comcast email account, which shouldn't affect my Gmail accounts. By "immediately" I mean "within minutes." Odd coincidence? Probably.
When I want your opinion,-
I'll read it in your entrails
     
reader50
Administrator
Join Date: Jun 2000
Location: California
Status: Offline
Reply With Quote
Apr 29, 2020, 03:37 PM
 
I think gmail has an option to accept untrusted devices. If you log into the webmail interface, you can find the control. Don't remember exactly where it it - it's been awhile. Probably in a security section.

It's also possible they want you to log into the webmail interface, and confirm the security exception from there. I've had that happen to friends with AT&T email before. AT&T farms mail services out to Yahoo. For awhile, anyone with an AT&T email account had to log into the yahoo mail interface once a year, or their mail would stop working. Took a fair amount of googling to figure that one out the first time.
     
Thorzdad  (op)
Moderator
Join Date: Aug 2001
Location: Nobletucky
Status: Offline
Reply With Quote
Apr 30, 2020, 07:42 AM
 
I went into the Gmail accounts via webmail. There isn't any control for adding/removing devices unless you have 2FA activated.
When I want your opinion,-
I'll read it in your entrails
     
Waragainstsleep
Posting Junkie
Join Date: Mar 2004
Location: UK
Status: Offline
Reply With Quote
Apr 30, 2020, 07:21 PM
 
If I remember rightly, you have to turn down the security settings in the account settings to allow insecure clients. Its a PITA.
I have plenty of more important things to do, if only I could bring myself to do them....
     
Thorzdad  (op)
Moderator
Join Date: Aug 2001
Location: Nobletucky
Status: Offline
Reply With Quote
May 4, 2020, 07:34 AM
 
So, this morning, Gmail is rejecting Mail.app's attempts to get into all of my Gmail accounts. It all worked yesterday, today it's gone to hell. @$#%&!!!
When I want your opinion,-
I'll read it in your entrails
     
Thorzdad  (op)
Moderator
Join Date: Aug 2001
Location: Nobletucky
Status: Offline
Reply With Quote
May 4, 2020, 08:11 AM
 
I went and logged into each account via the website. All the passwords worked fine. After logging out, Mail.app started slowly being able to get into the accounts for whatever reason. This is when I see that logging into the accounts using a browser triggered Google to send security alerts about the unrecognized logins. So, I click the link in each email to verify it was me. Of course, doing this via Mail.app triggers security alerts, too. So, I get into this horrible vicious circle where verifying the security alerts triggers another security alert. It's insane.
When I want your opinion,-
I'll read it in your entrails
     
reader50
Administrator
Join Date: Jun 2000
Location: California
Status: Offline
Reply With Quote
May 4, 2020, 11:20 AM
 
Log into gmail website.
Click your round profile icon on upper right (might be a colored dot with "t" in it)
-> choose "manage your google account"

On the settings page that comes up, click "security" in left sidebar.

On the Security page, scroll down. The setting you want is "Less secure app access" -> turn on access
You might also find something useful in the "Your Devices" block.
- or - something useful in the "Third-party apps with account access" block.
     
Thorzdad  (op)
Moderator
Join Date: Aug 2001
Location: Nobletucky
Status: Offline
Reply With Quote
May 4, 2020, 12:12 PM
 
"Less secure app access" is already on. It, of course, has a yellow "alert" icon. The only option there is to turn less secure access off.
Under "Devices" it clearly knows and recognizes this Mac.
There isn't a "Third-party apps with account access" section that I can find.
When I want your opinion,-
I'll read it in your entrails
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 04:55 AM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,