Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > macOS > screen lock doesn't work anymore after 10.4.6 update

screen lock doesn't work anymore after 10.4.6 update
Thread Tools
mike one
Grizzled Veteran
Join Date: Apr 1999
Location: sunny southern california
Status: Offline
Reply With Quote
Apr 24, 2006, 11:48 AM
 
hey gang, i'm in need of help to fix this problem:

I just updated to 10.4.6 and the auto screen lock feature no longer works after the screen saver kicks in. when i move the mouse, the regular desktop comes up---no login panel!!! i've double checked the security preferences window and the correct box is checked. unchecking and re-checking it doesn't fix the problem. fixing permissions doesn't fix the problem. going to the "lock screen" icon on the finder bar (you can put it there using keychain access) doesn't lock the screen! it works less than 10% of the time, restarting or logging out does not fix the problem.

thoughts on how to fix this?
     
proton
Senior User
Join Date: Nov 2000
Status: Offline
Reply With Quote
Apr 25, 2006, 07:39 AM
 
Are you waiting a few seconds after the screen saver activates before attempting to wake it?

Mac OS X 10.4 allows you to wake the machine without a password in the first few seconds after it falls asleep so you can avoid typing your password if it drops into the screen saver while you're actually still in front of the computer.

Are there any messages printed to the either the Console Log or System Log (viewed in Console)?

- proton
     
mike one  (op)
Grizzled Veteran
Join Date: Apr 1999
Location: sunny southern california
Status: Offline
Reply With Quote
Apr 25, 2006, 10:04 AM
 
yeah, i've been waiting a few seconds.
it also doesn't work when you use the drop down "lock screen" menu.

i logged into the other account on this computer and it works fine.... i wonder if there is a pref file i can delete to fix this... thoughts? :/
     
proton
Senior User
Join Date: Nov 2000
Status: Offline
Reply With Quote
Apr 29, 2006, 07:07 AM
 
This setting is stored in ~/Library/Preferences/ByHost/com.apple.screensaver.XXXXXXXXXXXX.plist (~ is your home folder).

- proton
     
mike one  (op)
Grizzled Veteran
Join Date: Apr 1999
Location: sunny southern california
Status: Offline
Reply With Quote
Apr 30, 2006, 02:21 PM
 
actually i deleted the login pref and that fixed it too
thanks so much for your help!
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 11:42 PM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,