Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > macOS > X-Window Problems, HELP!

X-Window Problems, HELP!
Thread Tools
naepstn
Forum Regular
Join Date: Apr 1999
Location: Edmonton, AB, Canada
Status: Offline
Reply With Quote
Nov 14, 2001, 01:52 PM
 
Hi folks.

For the life of me, I cannot figure out what's wrong with my Xfree86/XDarwin installation. I had it working properly, by installing the files listed in the article on MacOSX.org, then installing the latest version of XDarwin. It was really sweet!

Then, I decided to install the Gnu-Darwin base installation (part of which included XFree86_4.1). The installation seemed to fail on just about every package. After this, I haven't been able to get X to work. I've tried to delete the /usr/X11R6 and /etc/X11 directories and reinstall the way I did the first time, but that didn't work, I tried using pkg_delete and pkg_add to reinstall the XFree86 package. All to no avail. Arrrgggghhhhhhh.

When I try running XDarwin from the CLI, I get the following message...
Operating System: Darwin
Display mode: IOKit

Fatal server error:
Failed to connect as window server!
Quit the Mac OS X window server or use the -quartz option.

OsVendorFatalError
AbortDDX
Quitting XDarwin...
And when I try <./XDarwin -quartz>, I get...
Fatal server error:
QuartzOsVendorInit called without Quartz support.

OsVendorFatalError
AbortDDX
Quitting XDarwin...

FatalError re-entered, aborting
QuartzGiveUp called without Quartz support.

Abort
     
fitter
Senior User
Join Date: Jan 2000
Status: Offline
Reply With Quote
Nov 14, 2001, 03:41 PM
 
Have you tried downloading and reinstalling XDarwin? Those error message lead me to suspect that maybe your recent XFree install overwrote the XDarwin version. Repairing that is just a matter of reinstalling XDarwin.

Get it here: http://mrcla.com/XonX/
     
naepstn  (op)
Forum Regular
Join Date: Apr 1999
Location: Edmonton, AB, Canada
Status: Offline
Reply With Quote
Nov 14, 2001, 04:57 PM
 
Yeah, I tried that, and it didn't work.

However, thanks to the thread "Time-pressed College Student...", I deleted the X11 and X11R6 directories and XDarwin, and installed the .dmg package that was mentioned there, along with the OroborOSX window manager, and it all works again! Yeah!!!!

Thanks for you help though.
Cheers!
N
     
e-cyras
Fresh-Faced Recruit
Join Date: Nov 2001
Location: Switzerland
Status: Offline
Reply With Quote
Nov 15, 2001, 06:03 PM
 
hello! "startx -quartz" doesn't work! you must enter "startx -- -quartz", then i think, it should work fine!
     
Jelle Monkmater
Dedicated MacNNer
Join Date: Apr 2001
Location: World capital of drugs and prostitution. Hmmm... SEXTC...
Status: Offline
Reply With Quote
Nov 19, 2001, 05:45 AM
 
However, if the problem persists, even after trying startx -- -quartz, try deleting the .xinitrc file in your home directory.

Alternatively, edit the xinitrc file in /private/X11/etc/xinitrc/ to look something like this at the bottom:

--start--

# startup some sweet files or whatever it says

twm &
exec terminal -name login geoblabla

--end--

It just sounds like a corrupt .xinitrc.
The one you love and the one who loves you are never the same person.
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 11:36 AM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,