Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Hardware - Troubleshooting and Discussion > Mac Notebooks > Powerbook shuts down as soon as power lead removed - but battery is new

Powerbook shuts down as soon as power lead removed - but battery is new
Thread Tools
neal1973
Fresh-Faced Recruit
Join Date: Dec 2005
Location: Manchester, UK
Status: Offline
Reply With Quote
Oct 15, 2008, 12:08 PM
 
For some reason, as soon as I remove the powerlead - or it pulls out - my powerbook G4 1.67 shuts down after about 1-2 seconds.

The battery is 6 months old - and it worked for a while with no problems - and it is charged to 96%.

When I re-boot with powerlead attached, I have to reset the internal clock to today's date.

I vaguely remember reading something about this being due to a worn-out internal battery, which affects power management???

Does this sound right?

If so, is it easy to buy/fit a new internal battery? Does anyone have any links to instructions?

Any other ideas?

Many thanks in advance for any help I can get.

Cheers, Neal
     
Jolt21
Dedicated MacNNer
Join Date: May 2004
Status: Offline
Reply With Quote
Oct 16, 2008, 12:13 PM
 
Does your screen fizzle out right before the unit shuts down? I actually have a very similar problem, but mine last anywhere from 1 min to 10 min. It will eventually fizzle out and die if unplugged, but the length of time varies.
blah
     
analogika
Posting Junkie
Join Date: Feb 2005
Location: 888500128
Status: Offline
Reply With Quote
Oct 16, 2008, 12:35 PM
 
have you reset the PMU?

http://support.apple.com/kb/HT1431


It is, however, very likely that your internal backup battery is empty.
Instructions for replacing: http://www.ifixit.com/Guide/Mac/Powe...ry/64/5/Page-1
     
Judge_Fire
Mac Elite
Join Date: Jan 2001
Location: Helsinki, Finland
Status: Offline
Reply With Quote
Oct 16, 2008, 02:13 PM
 
I have the same G4 PB and its PRAM battery appears to be gone, too. Coincidentally, Apple released new MacBooks and somebody already placed an order...

Regardless, I used to have an issue with filling up the actual main battery on this Mac, too. For additional annoyance, when I plugged it in, it took a few minutes before it had enough juice in the battery to agree to start - it would not use direct power.

Turns out, I was using my wifes 12" PB's power brick, which gave me less watts than needed. Thanks to someone here, I realized that was the case, and we promptly sorted out our power sources.
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 05:35 AM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,