Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > Applications > Mail server switching

Mail server switching
Thread Tools
reader50
Administrator
Join Date: Jun 2000
Location: California
Status: Online
Reply With Quote
Jan 2, 2017, 11:23 PM
 
Since upgrading to Sierra, I found Mail sometimes switches the account you are sending from. I don't recall running into this with Yosemite.

Click on Compose New Message. (window opens, From: field set to an account. Usually last used.)
Fill in the To: field. (the From: field may silently change to another account! )
Write message.
*** recheck outgoing account, reset as needed ***
Send mail.

I didn't figure it out until several mails went out to people, sent through wrong accounts. In particular, if you have an account in their email domain, Mail consistently switches to that account after you fill in the To: field.

It didn't used to be necessary to *** recheck the From: field *** before sending. Does anyone know a way to stop Mail from altering the outgoing server after the window has opened? I couldn't find anything obvious in Mail Prefs. Onyx and TinkerTool lack any options for Mail.
     
Thorzdad
Moderator
Join Date: Aug 2001
Location: Nobletucky
Status: Offline
Reply With Quote
Jan 3, 2017, 06:29 PM
 
Originally Posted by reader50 View Post
Click on Compose New Message. (window opens, From: field set to an account. Usually last used.)
I've noticed sometimes in previous versions (I'm not on Sierra) that the From: field isn't necessarily the last one you used, but the last one you read mail from.
     
reader50  (op)
Administrator
Join Date: Jun 2000
Location: California
Status: Online
Reply With Quote
Jan 3, 2017, 10:48 PM
 
Yes, that's expected behavior. I usually click on the Inbox of the account I plan to send from. Then hit Compose, and it always comes up from that box. Now though, when I fill in the To: field, the sending account can silently change. If I've filled in the message before the To: field, it even leaves an unsent draft in the correct account. While sending from the unintended account.

If I could find a way to protest, Mail would say:
Originally Posted by Mail
I have altered the sending account. Pray I don't alter it any further.
     
reader50  (op)
Administrator
Join Date: Jun 2000
Location: California
Status: Online
Reply With Quote
Mar 24, 2017, 04:01 AM
 
I found a partial answer. The behavior is controlled from:

Mail preferences -> Composing (tab) -> Addressing: (section) -> Send new messages from: [popup menu]

The menu choices are each of your accounts, or "Automatically select best account". The automatic setting is the one that's gone stupid, and there are no controls to tweak its' behavior.

I chose the account I most frequently send from, and that stopped most of the annoyance. At least Mail has stopped changing the To field after the new message window has opened.
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 03:38 PM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,