Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > macOS > Annoying Window Behavior in Panther?

Annoying Window Behavior in Panther?
Thread Tools
bamchum
Forum Regular
Join Date: Dec 2002
Status: Offline
Reply With Quote
Nov 12, 2003, 12:21 AM
 
Anybody else seeing this?:

In the last day or two I've started to notice some bizarre behavior in Panther (that may or may not have anything to do with the OS): frequently when browsing using Safari or writing an e-mail using Mail, I'll find that the window I'm typing in or reading has somehow ceased to be in the foreground. What I mean is, if I'm using Safari, say, the close and resize buttons have gone grayscale and the window no longer pages down with the space bar. Yet Safari is still shown as the foreground application and no other Safari window has come to the foreground to replace the one I was working in.

It's a little hard to explain, but I hope you get the picture. Basically, the foreground window goes inactive. I'm quite sure that I'm not accidentally grazing the trackpad or anything like that (in fact, it just happened as I was typing this sentence).

It's quite annoying, as I have to take my hands off the keyboard and click on the browser or whatever again to bring the page forward. Any help on this much appreciated. It may be a third-party app, I realize. But it would be nice to nip this in the bud before it drives me totally insane.

Safari is just an example. It also happens in Mail and the Finder and iTunes and probably everything.

I did a little sleuthing with Activity Monitor and I think that coreservicesd is active every time it happens.
     
booboo
Mac Elite
Join Date: Oct 2000
Status: Offline
Reply With Quote
Nov 12, 2003, 08:32 AM
 
Originally posted by bamchum:
Anybody else seeing this?:
It's quite annoying, as I have to take my hands off the keyboard and click on the browser or whatever again to bring the page forward. Any help on this much appreciated. It may be a third-party app, I realize. But it would be nice to nip this in the bud before it drives me totally insane.

This used to happen in Jag too.

If you Command click the Window it usually brings it back to the front.

Another still-present annoyance is that if a (Cocoa app) window is 'maximized' and you try to drag it lower, so its bottom is below the Dock, it jumps back to the top of the screen. wtf?

The only way to stop this behaviour is to manually reduce the window's size a little. It can then be dragged anywhere, as it should.
     
JKT
Professional Poster
Join Date: Jan 2002
Location: London, UK
Status: Offline
Reply With Quote
Nov 12, 2003, 09:21 AM
 
For the original poster - are you accidentally activating Exposť on an app with just one window open? If so, the window shrinks ever so slightly and (obviously) no longer responds to keyboard input.

Originally posted by booboo:
Another still-present annoyance is that if a (Cocoa app) window is 'maximized' and you try to drag it lower, so its bottom is below the Dock, it jumps back to the top of the screen. wtf?
Doesn't do this for me and never has. The window's titlebar will pop-up above the Dock if you drag it below but that is sensible behaviour - is that what you mean?
     
bamchum  (op)
Forum Regular
Join Date: Dec 2002
Status: Offline
Reply With Quote
Nov 12, 2003, 09:55 AM
 
Originally posted by JKT:
For the original poster - are you accidentally activating Exposť on an app with just one window open?
No. And I'm not touching the trackpad, either. It happens even if my hands are well away from the machine.
     
bamchum  (op)
Forum Regular
Join Date: Dec 2002
Status: Offline
Reply With Quote
Nov 13, 2003, 04:24 AM
 
Turns out the culprit was LapCop, which is apparently incompatible with Panther.

Disable LapCop and you'll solve the problem (in case anyone else is seeing this).
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 01:41 PM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,