Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > Applications > iChat won't open anymore

iChat won't open anymore
Thread Tools
FlammableYurt
Junior Member
Join Date: Aug 2001
Status: Offline
Reply With Quote
Jan 15, 2004, 08:20 PM
 
I have no idea why, I was just using iChat earlier today, but now it just bounces for a second or two and then closes again. I tried using pacifist to get all the pkg files from the OS X cd, and I reinstalled iChat using those, but that didn't fix the problem... Any suggestions on what I could do to fix it?
I've been so many places, I've seen so many faces, and these blue, green, and purple HILLS
     
gorickey
Posting Junkie
Join Date: Nov 2001
Location: Retired.
Status: Offline
Reply With Quote
Jan 15, 2004, 08:24 PM
 
I'm sure you have restarted, right? Have you fixed permissions? Does it affect other users?
     
FlammableYurt  (op)
Junior Member
Join Date: Aug 2001
Status: Offline
Reply With Quote
Jan 15, 2004, 08:26 PM
 
I've logged out, restarted, repaired permissions (only on the harddrive that it's on, should I repair permissions for my other harddrive?) and it affects all other users, including root.
I've been so many places, I've seen so many faces, and these blue, green, and purple HILLS
     
gorickey
Posting Junkie
Join Date: Nov 2001
Location: Retired.
Status: Offline
Reply With Quote
Jan 15, 2004, 08:29 PM
 
Have you thrown away all associated .plist's?
     
FlammableYurt  (op)
Junior Member
Join Date: Aug 2001
Status: Offline
Reply With Quote
Jan 15, 2004, 08:30 PM
 
I moved them to a different location (first thing I did after restarting), and now there are new ones.
I've been so many places, I've seen so many faces, and these blue, green, and purple HILLS
     
gorickey
Posting Junkie
Join Date: Nov 2001
Location: Retired.
Status: Offline
Reply With Quote
Jan 15, 2004, 08:32 PM
 
Their is an "InstantMessenger.framwork" under /System/Library/PrivateFramworks/...I wonder if that is mucked up somehow...anyway to replace that?
     
FlammableYurt  (op)
Junior Member
Join Date: Aug 2001
Status: Offline
Reply With Quote
Jan 15, 2004, 08:37 PM
 
Hmm... Well, I don't really see any of that. Under System/Library I have a folder called Frameworks, and in there I don't see anything for iChat, nor instantmessanger, nor anything referring to PrivateFrameworks.

I am using iChat AV, in OS X.3.2.
I've been so many places, I've seen so many faces, and these blue, green, and purple HILLS
     
gorickey
Posting Junkie
Join Date: Nov 2001
Location: Retired.
Status: Offline
Reply With Quote
Jan 15, 2004, 09:04 PM
 
Originally posted by FlammableYurt:
Hmm... Well, I don't really see any of that. Under System/Library I have a folder called Frameworks, and in there I don't see anything for iChat, nor instantmessanger, nor anything referring to PrivateFrameworks.

I am using iChat AV, in OS X.3.2.
No, not Frameworks...PrivateFrameworks...

/System/Library/PrivateFrameworks/InstantMessage.framework/
     
FlammableYurt  (op)
Junior Member
Join Date: Aug 2001
Status: Offline
Reply With Quote
Jan 15, 2004, 09:15 PM
 
Ah, thanks... Heh, I did look for it, I swear .

So I found that, but if I remove it then iChat just bounces once then stops, and how could I replace it? I would think that reinstalling the app would replace it, but maybe it doesn't? I'll try to reinstall soon, when I have time.

THanks for the help!

And if anyone else might know what the source of this problem is, please tell me!
I've been so many places, I've seen so many faces, and these blue, green, and purple HILLS
     
gorickey
Posting Junkie
Join Date: Nov 2001
Location: Retired.
Status: Offline
Reply With Quote
Jan 15, 2004, 09:18 PM
 
Originally posted by FlammableYurt:
Ah, thanks... Heh, I did look for it, I swear .

So I found that, but if I remove it then iChat just bounces once then stops, and how could I replace it? I would think that reinstalling the app would replace it, but maybe it doesn't? I'll try to reinstall soon, when I have time.

THanks for the help!

And if anyone else might know what the source of this problem is, please tell me!
You can't remove the InstantMessage.framework as it holds the much needed "iChatAgent"...I've never used Pacifist, but if you can extract that sort of stuff, try to replace the whole InstantMessage.framework or the corresponding iChatAgent...

Simply re-installing the app will only install the actual iChat app, not replace the framework...

GOOD LUCK!
     
gorickey
Posting Junkie
Join Date: Nov 2001
Location: Retired.
Status: Offline
Reply With Quote
Jan 15, 2004, 09:27 PM
 
Also, what kind of errors is Console reporting when you launch iChat? Do you have a iChat.crash.log? iChatAgent.crash.log?
     
FlammableYurt  (op)
Junior Member
Join Date: Aug 2001
Status: Offline
Reply With Quote
Jan 15, 2004, 09:43 PM
 
Console doesn't report any errors. iChat bounces, starts to open (the arrow appears) but immediately closes, with no error, and console does not seem to notice... And no, I can't find a crash log anywhere for it.
I've been so many places, I've seen so many faces, and these blue, green, and purple HILLS
     
FlammableYurt  (op)
Junior Member
Join Date: Aug 2001
Status: Offline
Reply With Quote
Jan 15, 2004, 11:35 PM
 
No, nothing at all works... I've tried reinstalling iChat, the InstantMessenger frameworks, everything. If anyone has any idea how to fix this... I would be very happy to hear more ideas

And thanks a lot for all the help...
I've been so many places, I've seen so many faces, and these blue, green, and purple HILLS
     
Joost
Forum Regular
Join Date: Nov 1999
Location: Potemkin village
Status: Offline
Reply With Quote
Jan 15, 2004, 11:51 PM
 
Out of left field, and maybe not related at all, but doesn't the beta (ie, non-Panther version) expire today?
He that will eat the kernel must crack the nut.
     
gorickey
Posting Junkie
Join Date: Nov 2001
Location: Retired.
Status: Offline
Reply With Quote
Jan 15, 2004, 11:54 PM
 
Originally posted by Joost:
Out of left field, and maybe not related at all, but doesn't the beta (ie, non-Panther version) expire today?
No, I think it expired on 12/31/03....
     
FlammableYurt  (op)
Junior Member
Join Date: Aug 2001
Status: Offline
Reply With Quote
Jan 16, 2004, 10:01 PM
 
I'm really depressed now.... I just reinstalled OS X (but kept my old system folder), and iChat is STILL broken! What the hell is going on???

Not only have I reinstalled iChat and everythign related to it that I could find, but I installed the entire OS again... You would think that would solve the problem....

So... What do I do now? I'm completely lost... Help!!
I've been so many places, I've seen so many faces, and these blue, green, and purple HILLS
     
scottiB
Professional Poster
Join Date: Jan 2000
Location: Near Antietam Creek
Status: Offline
Reply With Quote
Jan 16, 2004, 10:03 PM
 
Originally posted by gorickey:
No, I think it expired on 12/31/03....
Mine expired today. Guess it's time to install Panther that I bought in October.
     
FlammableYurt  (op)
Junior Member
Join Date: Aug 2001
Status: Offline
Reply With Quote
Jan 16, 2004, 10:10 PM
 
*sigh* I keep getting excited when I see another post in this chat but the past three haven't been related at all...
I've been so many places, I've seen so many faces, and these blue, green, and purple HILLS
     
surfmonkey
Fresh-Faced Recruit
Join Date: Jan 2004
Status: Offline
Reply With Quote
Jan 16, 2004, 10:12 PM
 
Hi Flammable Yurt,

Were you using the iChat AV beta on Jaguar? If so, the software probably expired - you should be able to revert back to your original iChat or upgrade to the final version of iChat AV.
     
FlammableYurt  (op)
Junior Member
Join Date: Aug 2001
Status: Offline
Reply With Quote
Jan 17, 2004, 12:04 AM
 
No, I'm using the version of iChat that came with Panther. It's just.... broken. And nothing I've done has made a difference.

It's really annoying - I really don't have that many problems with my mac - but when I do have problems.... They're always really bizarre...
I've been so many places, I've seen so many faces, and these blue, green, and purple HILLS
     
surfmonkey
Fresh-Faced Recruit
Join Date: Jan 2004
Status: Offline
Reply With Quote
Jan 17, 2004, 01:21 AM
 
Hmm. Don't know what the issue is. When you reinstalled Panther you did you do an archive install (which installs a clean system but keeps all of your preferences, etc. so you get the best of both worlds. it feels like an upgrade but does a fairly clean install).

If you manually kept your system folder then I'm not surprised that you are still having problems after a new install. You probably kept whatever the issue was in your sys folder.

Mac OS X and new hardware come w 90 days of telephone support, if you're running Panther you should be covered. I'd give AppleCare a call.
     
FlammableYurt  (op)
Junior Member
Join Date: Aug 2001
Status: Offline
Reply With Quote
Jan 18, 2004, 02:53 AM
 
Yeah, hehe. I did do an archive installation. Didn't work and I don't understand why not... I miss iChat :'(
I've been so many places, I've seen so many faces, and these blue, green, and purple HILLS
     
Mercator
Fresh-Faced Recruit
Join Date: Jul 2001
Status: Offline
Reply With Quote
Jan 24, 2004, 02:48 AM
 
yurt,

I just encountered this problem today too. I have a DSL modem and a linksys router--I power cycled both and now it works. Must be local network related.

Merc
     
CharlesS
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Jan 24, 2004, 06:43 AM
 
Could you try the Console again? If you don't see any update after trying to launch iChat, try clicking "Reload" in the console - maybe last time it just didn't refresh the console window or something.

If you're having one of these failures to open, it really should be putting something in the console.

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 09:42 AM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,