Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > Applications > Photoshop Quick Mask weirdness

Photoshop Quick Mask weirdness
Thread Tools
Thorzdad
Moderator
Join Date: Aug 2001
Location: Nobletucky
Status: Offline
Reply With Quote
Oct 1, 2019, 06:44 PM
 
This is Photoshop in CS5. Sorry.

I do a lot of image manipulation, and I use Quick-Mask a lot. My normal routine is:
• Select a hard-edged brush, click Quick Mask button
• Use brush to mark area I want to copy
• Exit quick mask, select Inverse (because for some reason Photoshop initially selects everything outside the area you marked)
• Copy/Paste. No problems. (Yes, it's a lot of hand work, but it keeps the process fun.)

Today, though, I am getting this:
• Select a hard-edged brush, click Quick Mask button. As soon as I select Quick Mask, all of the color selection boxes...in the main tool palette, in the Color palette, and in the Type palette change to gray. If I click the dropdown in the Color palette, only the Grayscale slider is available. This is new behavior.

• Use brush to mark area I want to copy... You know how when you brush over an area to mask, it's a nice bright transparent red? Now, the red is very pale and very transparent.

• Exit quick mask... All the color selection boxes return to color.

• Select Inverse then Copy/Paste. The selection I copy/pasted is roughly 50% transparent, not solid. I have no idea why. The layer transparency is set to 100%. Interestingly, if I don't select Inverse, and then copy/paste, the pasted selection is solid, not transparent.

I'm tearing my hair out trying to figure out what double-secret function I might have accidentally enabled. Brush opacity and flow are at 100%. Mode is set to Normal. Layer Transparency is set to 100%. I get the same results using Pencil instead of Brush. If I use, for instance, the Lasso tool to select an area and copy/paste, it looks fine. Not transparent.

The color selection panels going gray when I enter QuickMask is a real puzzler. Well, the whole thing is a puzzler, of course.

Any help will be greatly appreciated. Thanks!
When I want your opinion,-
I'll read it in your entrails
     
andi*pandi
Moderator
Join Date: Jun 2000
Location: inside 128, north of 90
Status: Offline
Reply With Quote
Oct 1, 2019, 07:14 PM
 
my memory of fixing adobe cs5 apps generally was to trash preferences and restart. If you have custom workspaces move them to desktop then restart.

but quickmask... what color is in your choices at bottom of toolbar? hit d to reset to black and white, and d to swap foreground/background. possible you have a grey there?
     
Thorzdad  (op)
Moderator
Join Date: Aug 2001
Location: Nobletucky
Status: Offline
Reply With Quote
Oct 1, 2019, 07:22 PM
 
The colors in the toolbar are usually whatever colors I used last. Almost never a gray.
When I want your opinion,-
I'll read it in your entrails
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 12:14 PM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,