Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > macOS > Leopard/Snow Leopard Cannot Delete SOME Files from SAMBA Share?

Leopard/Snow Leopard Cannot Delete SOME Files from SAMBA Share?
Thread Tools
vwgtiturbo
Forum Regular
Join Date: Feb 2007
Status: Offline
Reply With Quote
Sep 8, 2009, 07:51 PM
 
Hello, I have had this issue on and off for a while, with both Leopard and now Snow Leopard... I have a Linux server set up, with several SAMBA shares. Permissions allow me to do pretty much anything I like. However, sometimes, when deleting backup copies of Apps from the server, Finder spits out an error that either 'Versions', 'Current', or 'Resources' is in use, and won't allow me to delete the item. Of course, if I SSH into the server as root, it deletes just fine. Is there some fine point that I am missing? Any assistance would be greatly appreciated.
Black 13" Widescreen MacBook
2.0Ghz C2D, 2GB RAM, 320GB HDD
Mac OS X v10.6 Snow Leopard
     
vwgtiturbo  (op)
Forum Regular
Join Date: Feb 2007
Status: Offline
Reply With Quote
Sep 8, 2009, 10:19 PM
 
I also receive the following error:
The Finder can’t complete the operation because some data in “ [Program/File Name]” can’t be read or written. (Error code -36)

With permissions being square on each end, this makes no sense. I noticed this in the Console log, and it occurs SOMEtimes when I get this error:
9/8/09 7:14:29 PM Finder[1400] Possible unresolved transaction race -112/(Mac/xxx.app,(null))

God, I HATE samba...
Black 13" Widescreen MacBook
2.0Ghz C2D, 2GB RAM, 320GB HDD
Mac OS X v10.6 Snow Leopard
     
vwgtiturbo  (op)
Forum Regular
Join Date: Feb 2007
Status: Offline
Reply With Quote
Sep 8, 2009, 11:19 PM
 
After doing much research, I haven't found much about this problem. I did see some posts about other issues, so I tried those suggestions, just for giggles. One of them concerned turning off 'posix locking' in smb.conf. This yielded no change. Another brought up adding 'unix extensions = off' to the conf, and not only did that not change anything, it actually created an entry in the smb log for "unknown parameter".
If I zip an app, it copies to the server just fine (and can be deleted) but leaving it as a ".app" causes problems.
Black 13" Widescreen MacBook
2.0Ghz C2D, 2GB RAM, 320GB HDD
Mac OS X v10.6 Snow Leopard
     
vwgtiturbo  (op)
Forum Regular
Join Date: Feb 2007
Status: Offline
Reply With Quote
Sep 9, 2009, 08:51 AM
 
Confirmed on a server at work... This issue exists on another server, with a nearly identical config. Writing Mac ".app" files results in above error. Possibly an issue with OSX metadata or resource forks when trying to write to an SMB share/ext3 filesystem???
Black 13" Widescreen MacBook
2.0Ghz C2D, 2GB RAM, 320GB HDD
Mac OS X v10.6 Snow Leopard
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 04:29 AM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,