Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > Applications > problem after installing iphoto 5.0(1)

problem after installing iphoto 5.0(1)
Thread Tools
terry123
Fresh-Faced Recruit
Join Date: Mar 2005
Status: Offline
Reply With Quote
Mar 22, 2005, 12:07 AM
 
I recently attempted to install iphoto 5. All was going well until the upgraded iphoto went to load the photos. The photos never loaded. Just a spinning timer/not colored ball. I let it run for a while as there are greater than 5000 pics in this library. Suspecting a crash, I quit the program and then restarted iphoto. Now all my thumbs are grey and the program doesn't see any of the pictures in the pictures library. I suspect there was a corrupt file in the library that made it crash. The pictures are still in the library. iPhoto just can't find them. I tried to rebuild the library-the program said something was locked and I couldn't do it. I tried to repair permissions-no change. I ran disk utility-no change. I threw the application out, threw the thumb....data,thumb...jpg and also the com.apple....iphoto, threw them away, restarted the computer and still had the same result-greater than 500 grey thumbs that couldn't find my pictures. I can't wait for tiger so I can do a clean install of the whole computer. How do I get me pics back it the meantime? I am at the point where I am ready to re-import all of them into a fresh iphoto. Is there an easy way to do this from the existing library? Should I back up the library to dvd(s) and then try to reimport them into a fresh iphoto???? Sorry for the long windedness...imac 15 800mhz,768ram,10.3.8,superdrive
     
JazzCatDRP
Mac Enthusiast
Join Date: Sep 2004
Status: Offline
Reply With Quote
Mar 22, 2005, 01:16 AM
 
I had the same exact problem as did a bunch of other folks. This is the solution: Move your library to the desktop. Then, launch iPhoto and create a new library. Once you're in the new empty library, select "Add to library", and choose your iPhoto library that was moved to the desktop. You'll lose some things like keywords and such, but for me it kept it all organized as far as dates and all that.
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 11:34 AM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,