Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Hardware - Troubleshooting and Discussion > Mac Notebooks > Macbook Pro Issues

Macbook Pro Issues
Thread Tools
orb1692
Fresh-Faced Recruit
Join Date: May 2010
Status: Offline
Reply With Quote
May 23, 2010, 07:34 PM
 
Hi, I've had my Macbook Pro for 1 year now and recently:

When connected to a network via airport for an extended period of time(3 or more hours) it jus disconnects from the network although it still shows the signal bars. Then when i try to reconnect airport either turns off or it doesn't connect. The only fix working for now is to restart my computer and try to reconnect. Also if i do turn my airport off its doesn't want to turn on when i try to. Btw i have the refreshed model of the 15-inch Macbook Pro 2.66 GHz (non-removable battery) and im running Snow Leopard Version 10.6.3.

In addition, I have an issue with my laptop also totally freezing on me and not responding to any commands.This too also causes me to hard restart my laptop.

Im just wondering if anybody has any quick fixes since i do not live anywhere near an apple store.
     
amazing
Professional Poster
Join Date: Jan 2003
Status: Offline
Reply With Quote
May 23, 2010, 08:01 PM
 
About the airport network problem: download iStumbler and check how crowded your airwaves are. If there are loads of nearby wireless hotspots, be sure to switch your WAP/router to a clear channel that hasn't been taken. Does your router allow you to regulate how strong a signal it broadcasts?

Any stations coming in close to the same strength as yours? Any open stations nearby that could confuse your MBP? Anybody use the microwave or cordless phone when the disconnects happen?

About the freezes: did they start just recently, and did you recently install something? What are you doing when it freezes? How frequent? Here's a tip: Establish a second, plain vanilla user account, no modifications. Does that new account freeze in the same way? Are there any clues in the crash log?
     
ghporter
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
May 23, 2010, 08:01 PM
 
Welcome to our forums!

For reasons nobody understands, sometimes Airport cards just lose their minds. The classic example is "wake from sleep" with the card not connecting-this happens because the card doesn't get the signal that the computer went to sleep and that it needs to re-find the network. Your issue probably has nothing to do with this-it's more likely some sort of software thing, but without an idea of what software you have installed, I couldn't say just what sort of software thing it is.

Is everything up to date? Having the latest OS version doesn't guarantee that everything else is current, so your apps and such may need touching up. There are a few programs out there that just don't play nice, and if they have some problem or other, they could simply hang the whole system. This symptom is why I don't think it's aproblem with your AirPort card itself, but rather a software issue.

Again, welcome to our forums!

Glenn -----OTR/L, MOT, Tx
     
seanc
Moderator Emeritus
Join Date: Apr 2005
Location: Cambridge, UK
Status: Offline
Reply With Quote
May 23, 2010, 08:26 PM
 
Regarding freezes, when this next happens, please try plugging in an external keyboard & mouse and see if you can use the laptop that way, this rules out a bad connection from the top case to the logic board.
     
Big Mac
Clinically Insane
Join Date: Oct 2000
Location: Los Angeles
Status: Offline
Reply With Quote
May 23, 2010, 08:53 PM
 
I don't think it's a keyboard and mouse thing, personally. It sounds like he's describing hard freezes. orb, that should not be happening in OS X and points to a serious issue with your computer. Have you run the Hardware Test?

Regarding your WIFI problem, that isn't a normal issue either. Have you used it on a different WIFI network to see if it exhibits the same behavior? It could be your WIFI router at fault or your computer.
( Last edited by Big Mac; May 23, 2010 at 10:00 PM. )

"The natural progress of things is for liberty to yield and government to gain ground." TJ
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 02:48 AM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,