Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > Applications > Mail won't send (but Webmail will)

Mail won't send (but Webmail will)
Thread Tools
Danoir
Forum Regular
Join Date: Oct 1999
Location: Chicago, IL
Status: Offline
Reply With Quote
Mar 14, 2005, 12:37 PM
 
I've been having a problem with Mail the last few days. I hit send, it doesn't send. The little spinner in the upper right spins indefinitely, eventually the message itself pops up with something like "use this server, try sending later" and some other third choice. When I try sending the same message through Webmail, there's no problem.

I tried pinging mail.mac.com and it says none of the 10 packets got through. I think my port number is 25 (I'm writing this from work). Should I try changing the port?

Thanks,
D
     
Mithras
Professional Poster
Join Date: Oct 1999
Location: :ИOITAↃO⅃
Status: Offline
Reply With Quote
Mar 14, 2005, 01:20 PM
 
Perhaps to stop viruses, your workplace IT management has blocked outbound traffic on port 25 (other than their own server).
Or since even your pings don't get through, perhaps your workplace has put in a firewall blocking all outbound traffic other than port 80?
     
Danoir  (op)
Forum Regular
Join Date: Oct 1999
Location: Chicago, IL
Status: Offline
Reply With Quote
Mar 14, 2005, 01:30 PM
 
Gosh. I wrote that without giving enough information.

1. Receiving is no problem. I still get plenty of mail.
2. This problem has only recently cropped up (2 days ago). Nothing about my network has changed to my knowledge.
3. This is referring to a home network. I have DSL from SBC coming into a Linksys router 802.11g, with an AirPort Express extending the signal to my iBook. I have no firewall in use on the iBook and the settings on the Linksys and APE are pretty much default.

Like I said, I think I'm using port 25. Is there another port I should try?

Thanks again,
D
     
ChrisF
Senior User
Join Date: Apr 2002
Status: Offline
Reply With Quote
Mar 14, 2005, 02:48 PM
 
Originally posted by Danoir:
3. This is referring to a home network. I have DSL from SBC coming into a Linksys router 802.11g, with an AirPort Express extending the signal to my iBook. I have no firewall in use on the iBook and the settings on the Linksys and APE are pretty much default.
SBC has recently started blocking port 25 to external SMTP servers. I believe .mac has an alternate port available and you can contact SBC asking them to reenable port 25 access though I do not have details on that.
     
bbales
Mac Elite
Join Date: Jan 2003
Location: suburban Chicago
Status: Offline
Reply With Quote
Mar 14, 2005, 03:11 PM
 
Yes, ameritech has blocked port 25. On mail, use 587 instead. (There's an article about this on the Apple site, by the way -- I think it's on the discussion section.)

And you can also petition ameritech on one of its "abuse of services" forms to have it unblocked. I've done both these things in recent weeks.
     
Danoir  (op)
Forum Regular
Join Date: Oct 1999
Location: Chicago, IL
Status: Offline
Reply With Quote
Mar 15, 2005, 10:49 AM
 
Thanks! It worked like a charm. Not only that, but I'm convinced it takes less time to send now. Hooray!

D
     
Big Mac
Clinically Insane
Join Date: Oct 2000
Location: Los Angeles
Status: Offline
Reply With Quote
Mar 15, 2005, 12:17 PM
 
Wow, blocking port 25 is really asinine. The providers explicitly want people to use their mail servers to send messages labeled as coming from other domains, as opposed to sending them from the mail servers they're supposed to come from?

"The natural progress of things is for liberty to yield and government to gain ground." TJ
     
ChrisF
Senior User
Join Date: Apr 2002
Status: Offline
Reply With Quote
Mar 15, 2005, 12:44 PM
 
Originally posted by Big Mac:
Wow, blocking port 25 is really asinine. The providers explicitly want people to use their mail servers to send messages labeled as coming from other domains, as opposed to sending them from the mail servers they're supposed to come from?
The main goal is to block compromised Windows machines which carry worms that spread via an internal SMTP server on the compromised computer. Blocking this controls the spread of spam and worms... but I agree it's an inconvenience.
     
just_switched
Fresh-Faced Recruit
Join Date: Mar 2005
Location: Right here in Chicago
Status: Offline
Reply With Quote
Mar 15, 2005, 03:29 PM
 
I *still* have the same problem. Until now, I didnt know about the port problem. But when I tried to send the machine via SBC DSL account, it also acted up but eventually it went through. Thanks for all the info. I am going to change the port setting to see if it works.

M
     
bbales
Mac Elite
Join Date: Jan 2003
Location: suburban Chicago
Status: Offline
Reply With Quote
Mar 15, 2005, 11:19 PM
 
Originally posted by just_switched:
I *still* have the same problem. Until now, I didnt know about the port problem. But when I tried to send the machine via SBC DSL account, it also acted up but eventually it went through. Thanks for all the info. I am going to change the port setting to see if it works.

M
I THINk you'll find that with SBC you'll have to go on the SBC web site, on the "member services" part and fill out an "abuse of services" form. That's what I had to do anyway. Service was pretty fast, though.
     
Krusty
Professional Poster
Join Date: Oct 1999
Location: Always within bluetooth range
Status: Offline
Reply With Quote
Mar 16, 2005, 12:01 AM
 
This happened to me a year or so ago ... Bellsouth DSL started blocking outgoing mail servers other than its own and nothing other than my Bellsouth account would work for sending. However, this is a much milder problem than it even appears on the surface.

Besides switching from port 25 to 587, you can also simply change your non-ISP accounts, including .mac, to use your ISPs outgoing mail server for sending. It works fine and mail from your .mac account will still appear to recipients as being from your .mac account. As people have mentioned, this thing has been put in place to stop spammers and the spread of virii .. it does NOT stop you from sending mail from other accounts. For example, my .mac account has an incoming server of mail.mac.com and an outgoing server of mail.lig.bellsouth.net. Works just fine "piggy back" on my ISPs outgoing mail server.
     
Tsilou B.
Senior User
Join Date: May 2002
Location: Austria
Status: Offline
Reply With Quote
Mar 16, 2005, 04:59 AM
 
Originally posted by Krusty:
This happened to me a year or so ago ... Bellsouth DSL started blocking outgoing mail servers other than its own and nothing other than my Bellsouth account would work for sending. However, this is a much milder problem than it even appears on the surface.

Besides switching from port 25 to 587, you can also simply change your non-ISP accounts, including .mac, to use your ISPs outgoing mail server for sending. It works fine and mail from your .mac account will still appear to recipients as being from your .mac account. As people have mentioned, this thing has been put in place to stop spammers and the spread of virii .. it does NOT stop you from sending mail from other accounts. For example, my .mac account has an incoming server of mail.mac.com and an outgoing server of mail.lig.bellsouth.net. Works just fine "piggy back" on my ISPs outgoing mail server.
The problem with this approach is that more and more email providers support SPF. This means they publish a list of all their SMTP servers and encourage other providers to mark all messages as spam that have a sender's address from their network, but do not come from one of their published SMTP servers.
I have always had a free email address and its SMTP server always appends small advertising messages to all emails I send. So I used to send them via the SMTP server of my university. But my free email provider now supports SPF, and that means that everytime I send email to someone whose provider also supports SPF, the message is automatically sorted out and doesn't reach the recipient. So before you start to use the SMTP server of your internet provider, check if you email provider supports SPF. (.mac currently does not, so there should be no problems.)
     
   
Thread Tools
 
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Top
Privacy Policy
All times are GMT -4. The time now is 09:43 PM.
All contents of these forums © 1995-2017 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2017, Jelsoft Enterprises Ltd.,